[mythtv-users] Always prescaling theme images on startup

Michael T. Dean mtdean at thirdcontact.com
Thu Mar 8 21:49:01 UTC 2007


On 03/08/2007 03:59 PM, R. G. Newbury wrote:
>>  People who run at the same resolution as the theme don't see this :)   (eg/ those who run at 800x600, for the "normal" 4:3 themes...)
>>     
> Gee, I'm running Iuliua at 800x600 and I see the scaling stuff every 
> time I fire up mythfrontend (or exit from Setup:Appearance....)
>   

I'm guessing that for all of you who see it every time, such that every 
time it takes the same amount of time, you're running mythfrontend in a 
misconfigured environment.  I.e. check that you have a valid HOME 
environment variable and that you actually have write access to 
$HOME/.mythtv and all its subdirectories and all their contents.  If you 
don't have a HOME environment variable specified, Myth will try to use 
/.mythtv --off the root of the filesystem--where you likely don't have 
write access.  And, it wouldn't hurt to shut down mythfrontend and run:

rm -r $HOME/.mythtv/{theme,osd}cache

(where HOME /must/ be set to the same value you have in the environment 
that's starting mythfrontend).

As far as Iulius at 800x600 goes, I have no idea what's happening.  It 
should not even show the dialog.  Are you sure you don't have a value 
for "GUI width (px)" and/or "GUI height (px)" other than 800 and 600 
respectively or 0 (for fullscreen) for both?  If you run X at 800x600, 
but you don't run Myth fullscreen, you're not running Myth at 800x600.

Mike


More information about the mythtv-users mailing list