[mythtv-users] S/PDIF in?

Hugh mythtv at piggie.org
Wed Mar 21 02:05:28 UTC 2007


All,

I've got an Abit NF-M2 nView motherboard which has S/PDIF input and
output ports. The output seems to be working fine, but I can't seem to
get the input working (no sound). This is on Fedora Core 6 and when I
run alsamixer and look at the Capture options, the IEC958 is in red and
has no "bar" for gain. Below are what's in a couple of the alsa files.


asound.state (partial):

        control.30 {
                comment.access 'read write'
                comment.type BOOLEAN
                comment.count 1
                iface MIXER
                name 'IEC958 Capture Switch'
                value true
        }
        control.31 {
                comment.access read
                comment.type IEC958
                comment.count 1
                iface MIXER
                name 'IEC958 Capture Default'
                value
'0400000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
        }





asound.conf:

#Generated by system-config-soundcard, do not edit by hand
#SWCONF
#DEV 1
defaults.pcm.card 0
defaults.pcm.device 1
defaults.ctl.card 0


I'm relatively experienced with linux from the server standpoint, but
new to it from the x-windows/multimedia side of things.

Thanks in advance,

Hugh


More information about the mythtv-users mailing list