[mythtv-users] FC6 "lirc dead but subsys locked"

Nick Morrott knowledgejunkie at gmail.com
Fri May 25 16:00:24 UTC 2007


On 25/05/07, Tye Newman <newman_t at sbcglobal.net> wrote:
> Hey All,
>
> I am new to all this.
>
> I have install FC6 using the Myth(TV)ology.  Things are working great except
> for lirc.  I have a PVR-150 with the new grey and black remote.  When I
> first set up the system I installed lirc and tested it using irw.  It worked
> great.  I even setup the mythtv keys and was able to navigate MythTV with
> the remote.
>
> Without change anything I rebooted the system and the remote quite working.
> I checked the status of the lircd and it stated that "lirc dead but subsys
> locked".
>
> What happened!?  I have been reading every post on this list and about a
> million google searches to no avail.
>
> As background I am running:
>
>     Athlon 64 X2 +3800
>     Gigabyte GA-M61VME-S2 (Vnidia chipset)
>     512MB DDR2 memory
>     PVR-150 (non-mce)
>
> I noticed that the /dev/lirc0 does not exsist either (don't know if that
> matters).  It never occurred to me to check the /dev list when things were
> working.

This error can occur if lircd is started with a missing LIRC device.
You should have a /dev/lirc0 device for your PVR-150, and a /dev/lirc
symlink to it. The LIRC package from atrmps.net should include a udev
rule to create the symlink for you. You should also have a /dev/lircd
socket device which should be created automatically when lircd is
started.

As Mike stated, if using the IR receiver on the PVR-150, you need the
lirc-i2c and lirc-dev modules loaded, with a valid remote
configuration for your remote control in /etc/lircd.conf.

Running:

# lsmod |fgrep "lirc"

will list currently loaded LIRC modules.

-- 
Nick

MythTV Official wiki:
http://mythtv.org/wiki/
MythTV users list archive:
http://www.gossamer-threads.com/lists/mythtv/users

"An investment in knowledge always pays the best interest." - Benjamin Franklin


More information about the mythtv-users mailing list