[mythtv-users] intel I810 XvMC Saga

Mitch Gore mitchell.gore at gmail.com
Sun Nov 4 14:58:53 UTC 2007


On Nov 3, 2007 9:22 PM, R. G. Newbury <newbury at mandamus.org> wrote:

> ianvcruz at onelinkpr.net wrote:
> > hello, I can not make XvMC work in mythtv or outside myth. i have been
> trying
> > for over a month without success.I have an Intel integrated video card ,
> I'm
> > using intel drivers I810 and my distro is debian etch. i have "
> libI810XvMC "
> > in  /etc/X11/XvMCConfig but there is no symlink, i have try with other
> computer
> > and Nvidia geforce 6200 and have the same isues with XvMC . Mythtv
> frontend show
> > this:
> >
> >  2007-11-02 20:02:59.414 Using runtime prefix = /usr/local
> > 2007-11-02 20:02:59.620 DPMS is active.
> > 2007-11-02 20:03:00.160 New DB connection, total: 1
> > 2007-11-02 20:03:00.238 Connected to database 'mythconverg' at host:
> localhost
> > 2007-11-02 20:03:00.243 Total desktop dim: 1024x768, with 1 screen[s].
> > 2007-11-02 20:03:00.275 Using screen 0, 1024x768 at 0,0
> > 2007-11-02 20:03:00.341 Current Schema Version: 1160
> > 2007-11-02 20:03:00.377 mythfrontend version: 0.20.20070821-1
> www.mythtv.org
> > 2007-11-02 20:03:00.378 Enabled verbose msgs:  important general
> > 2007-11-02 20:03:01.224 Total desktop dim: 1024x768, with 1 screen[s].
> > 2007-11-02 20:03:01.226 Using screen 0, 1024x768 at 0,0
> > 2007-11-02 20:03:01.228 Switching to square mode (G.A.N.T.)
> > 2007-11-02 20:03:01.300 Using the Qt painter
> > mythtv: could not connect to socket
> > mythtv: No such file or directory
> > lirc_init failed for mythtv, see preceding messages
> > 2007-11-02 20:03:01.849 Joystick disabled.
> > 2007-11-02 20:03:03.201 Loading from:
> > /usr/local/share/mythtv/themes/G.A.N.T./base.xml
> > 2007-11-02 20:03:03.331 Loading from:
> > /usr/local/share/mythtv/themes/default/base.xml
> > 2007-11-02 20:03:03.496 Registering Internal as a media playback plugin.
> > 2007-11-02 20:03:08.077 New DB connection, total: 2
> > 2007-11-02 20:03:08.079 Connected to database 'mythconverg' at host:
> localhost
> > 2007-11-02 20:03:08.197 Connecting to backend server: 127.0.0.1:6543(try 1 of 5)
> > 2007-11-02 20:03:08.248 Using protocol version 31
> > 2007-11-02 20:03:08.253 TV: Attempting to change from None to
> WatchingLiveTV
> > 2007-11-02 20:03:08.302 Using protocol version 31
> > 2007-11-02 20:03:08.503 DPMS Deactivated
> > 2007-11-02 20:03:09.668 NVP: Disabling Audio, params(-1,2,44100)
> > 2007-11-02 20:03:09.834 VideoOutputXv: XvMCTex: Init failed
> > 2007-11-02 20:03:09.835 VideoOutputXv: XVideo Adaptor Name: 'Intel(R)
> Video Overlay'
>
> > 2007-11-02 20:03:16.030 Video timing method: USleep with busy wait
> > 2007-11-02 20:03:20.520 NVP: Prebuffer wait timed out 10 times.
> > 2007-11-02 20:03:21.387 VideoOutputXv Error: XvMC output requested, but
> is not
> > supported by display.
> > Xlib:  extension "XVideo-MotionCompensation" missing on display ":0.0".
> > Xlib:  extension "XVideo-MotionCompensation" missing on display ":0.0".
> > XvMCWrapper: Could not load hardware specific XvMC library
> "libI810XvMC".
> > libI810XvMC: cannot open shared object file: No such file or directory
> > 2007-11-02 20:03:21.786 VideoOutputXv: XvMCTex: Init failed
> > 2007-11-02 20:03:21.794 VideoOutputXv: XVideo Adaptor Name: 'Intel(R)
> Video Overlay'
>
> You do not say what Intel chipset is in your 'integrated video card'.
> Sorry but XvMC does not work on intel chipsets above the i830 with
> either the I830 or the intel driver.
> There are Intel guys working on the intel driver to get it working with
> xorg. There is at present an experimental xvmc-i915 branch, which may,
> when completed, bring xvmc to the intel chipset series up to the i965.
>
> And, I have no idea when that will happen...
>
> In the meantime, you must be doing something wrong if you cannot get
> xvmc working with an Nvidia 6200. (Take your pick of any one of about a
> hundred steps or settings which could be wrong!) There are various
> step-by-step instructions on various web-sites. Even though you are on
> debian, Jarod Wilson's site will help as will the wiki.
> Unfortunately, these setups require us to get 100 individual things
> *exactly* right.
> To err is human. Trying to do this proves how human we are!.
>
> Geoff
>
>
>
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>



What are you talking about XvMC is so easy to get working with the nvidia
drivers.  Not sure what you did with installing them with a 100 steps..

I dont use debian but i am sure it has some version of apt-get or yum.  So,
install the correct repo, do a yum install *graphic driver name* put the
XvMC link int /etc/X11/ and your good to go.

Mitchell
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20071104/32d058c1/attachment.htm 


More information about the mythtv-users mailing list