[mythtv-users] Can't play DVDs

Phil Bridges gravityhammer at gmail.com
Fri Nov 30 01:51:52 UTC 2007


I'm trying to play DVDs in my newest frontend, and, for the life of
me, can't.  I have the DVD (/dev/hdc) mounted as /mnt/dvd.  I'm using
the Internal player.  Here's what happens when I try to play a DVD:

2007-11-29 20:01:25.519 XMLParse::LoadTheme using
/usr/share/mythtv/themes/default/keyboard/en_us_ui.xml
QDate::fromString: Parameter out of range
2007-11-29 20:01:34.500 TV: Attempting to change from None to
WatchingPreRecorded
libdvdread: Using libdvdcss version 1.2.9 for DVD access
libdvdread: Attempting to use device /dev/hdc mounted on /mnt/dvd for
CSS authentication

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x0000016c
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_0.VOB at 0x000001ec
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x00026ab9
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_0.VOB at 0x002a7fe3
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_1.VOB at 0x002a801c
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_0.VOB at 0x002aaf48
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_1.VOB at 0x002aaf81
libdvdread: Elapsed time 1
libdvdread: Get key for /VIDEO_TS/VTS_04_0.VOB at 0x002b9140
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_04_1.VOB at 0x002b9179
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_05_0.VOB at 0x002cee4d
libdvdread: Elapsed time 0
libdvdread: Found 4 VTS's
libdvdread: Elapsed time 1
libdvdnav: Using dvdnav version 0.1.10-xine from http://xine.sf.net
libdvdnav: Can't read name block. Probably not a DVD-ROM device.
libdvdnav: Unable to find map file '/home/mythtv/.dvdnav/.map'
libdvdnav: DVD disk reports itself with Region mask 0x00fe0000. Regions: 1
2007-11-29 20:01:36.739 Opened DVD device at /mnt/dvd
libdvdread: Invalid IFO for title 14 (VTS_14_0.IFO).
libdvdnav: ifoOpenVTSI failed
2007-11-29 20:01:36.964 There are 17 titles on the disk
2007-11-29 20:01:36.964 Title 0 has 0 parts.
2007-11-29 20:01:36.964 Title 1 has 22 parts.
2007-11-29 20:01:36.964 Title 2 has 2 parts.
2007-11-29 20:01:36.964 Title 3 has 2 parts.
2007-11-29 20:01:36.965 Title 4 has 2 parts.
2007-11-29 20:01:36.965 Title 5 has 6 parts.
2007-11-29 20:01:36.965 Title 6 has 2 parts.
2007-11-29 20:01:36.965 Title 7 has 2 parts.
2007-11-29 20:01:36.965 Title 8 has 2 parts.
2007-11-29 20:01:36.965 Title 9 has 2 parts.
2007-11-29 20:01:36.965 Title 10 has 2 parts.
2007-11-29 20:01:36.965 Title 11 has 2 parts.
2007-11-29 20:01:36.965 Title 12 has 2 parts.
2007-11-29 20:01:36.965 Title 13 has 2 parts.
2007-11-29 20:01:36.965 Title 14 has 1 parts.
2007-11-29 20:01:36.965 Title 15 has 1 parts.
2007-11-29 20:01:36.965 Title 16 has 1 parts.
2007-11-29 20:01:36.972 DPMS Deactivated
2007-11-29 20:01:36.975 DVDNAV_STOP
2007-11-29 20:01:36.988 NVP::OpenFile(): Error, couldn't read file: /mnt/dvd
2007-11-29 20:01:36.992 TV Error: StartPlayer(): NVP is not playing
after 20000 msec
2007-11-29 20:01:36.992 TV: Changing from None to WatchingPreRecorded
2007-11-29 20:01:36.996 TV: Attempting to change from
WatchingPreRecorded to None
2007-11-29 20:01:36.997 TV: Changing from WatchingPreRecorded to None


I have the same DVD playing in my other two DVDs fine.  Any
suggestions on which direction to look to get this fixed?


More information about the mythtv-users mailing list