[mythtv-users] Still no AC3 passthrough...

Greg Arena gma at gmadigitaldesign.com
Mon Oct 15 02:44:32 UTC 2007

There must have been something wrong with the ALSA setup that I
had on my RHEL5 installation. After installing MythDora 4.0, I
was able to get the AC3 passthrough to "just work". I can now
hear 5.1 audio on the HD channels at last through the Turtle
Beach Riviera card.

I still don't know what it could have been that screwed it all
up, but then again, I did a lot of tinkering on the RHEL5
installation to get acquainted with MythTV before I decided it
was good enough to take downstairs from my home office and hook
it up to my receiver & HDTV set. I could have messed things up a
month or two ago for all I know.

Thanks again to all who responded to my question!
Greg A.

-----Original Message-----
From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Henry A
Harper III
Sent: Friday, October 12, 2007 6:47 PM
To: Discussion about mythtv
Subject: Re: [mythtv-users] Still no AC3 passthrough...

> 	I un-muted the IEC958 Output in alsamixer. Until I did
> that, I was getting no audio at all. So that part appears to be
> correct - once I did that, I was able to get 2-channel audio
> working before I tried getting the pass-through to work again.
> 	I'd appreciate it if you could tell me what settings are
> working for you. I have a feeling I may have tried them
> I'm beginning to think the problem may be somewhere else
> as I said in another post, running "aplay -L" results in a
> segmentation fault and I did a lot of experimenting, upgrading
> ALSA, etc.

I'm not Darren, but I can't help but feel responsible for
recommending the
Riviera. I currently don't have a .asoundrc at all, my myth (SVN
14482) settings are:

Audio output device: ALSA:default
Passthrough output device: Default (not "default")
Enable AC3 to SPDIF passthrough: checked
Aggro sound buffering & use internal volume: not checked

In alsamixer all my "iec958" items are muted except for Output
and 5V. My
"aplay -l" output is the same as yours, but I don't get a
segfault with
"aplay -L" - I definitely would look into that. My ALSA version

mythtv-users mailing list
mythtv-users at mythtv.org

More information about the mythtv-users mailing list