[mythtv-users] New Grabber Installation - Help!

Rod Roark rod at sunsetsystems.com
Sat Sep 1 19:57:20 UTC 2007


I've written a new XMLTV grabber that scrapes information from
directv.com.  It validates properly according to the XMLTV validation
tool.

Now my problem is installing it into my existing MythTV installation,
KnoppMyth R5F1.  Can someone tell me what the correct procedure is
for doing this?  I tried renaming my grabber to /usr/bin/tv_grab_cz
since MythTV seems to know about that one, but with limited success.

I've really been groping in the dark with my installation and testing.
What I've been doing is removing my video source, creating it again
(named DirecTV) with tv_grab_cz as the grabber, creating the input
connection, restarting the backend, copying my grabber configuration
file to /home/mythtv/.mythtv/DirecTV.xmltv, and running
mythfilldatabase.

Anyway, the main issue is I can't get mythfilldatabase to recognize my
channel numbers.  Supposedly these are passed via the <display-name>
tags, but I'm at a loss to understand what the rules are.
tv_grab_na_dd was generating channel information like this:

  <channel id="I10021.labs.zap2it.com">
    <display-name>254 AMC</display-name>
    <display-name>254 AMC DITV862:-</display-name>
    <display-name>254</display-name>
    <display-name>AMC</display-name>
    <display-name>AMC</display-name>
    <display-name>Satellite</display-name>
  </channel>

which I tried duplicating, but no luck.  No matter what I do, the
channel ID string ends up in the "channel" table where the channel
number should be.

What do I need to do?

Rod


More information about the mythtv-users mailing list