[mythtv-users] Yum upgrade to SD missing dependencies

Remco Treffkorn remco at rvt.com
Sun Sep 2 20:48:14 UTC 2007


On Sunday 02 September 2007, Lan Barnes wrote:
> I had to repair yum (yum clean all) and fix a table in mythconverg before
> my backup would work, but I was feeling pretty cocky when I finally ran:
>
>   yum update \*myth\*
>
> Lots of activity w/o error, but it finally failed to find all the
> dependencies. Here are yum's complaints:
>
> Error: Missing Dependency: mythtv-frontend-api = package is needed by
> package mythstream
> Error: Missing Dependency: installed. is needed by package mythstream
> Error: Missing Dependency: is is needed by package mythstream
> Error: Missing Dependency: not is needed by package mythstream
> Error: Missing Dependency: libmythavformat-0.20.1.so.0 is needed by
> package libmyth-devel
> Error: Missing Dependency: libmythavutil-0.20.1.so.0 is needed by package
> libmyth-devel
> Error: Missing Dependency: libmythupnp-0.20.1.so.0 is needed by package
> libmyth-devel
> Error: Missing Dependency: libmythavcodec-0.20.1.so.0 is needed by package
> libmyth-devel
> Error: Missing Dependency: libmythtv-0.20.1.so.0 is needed by package
> libmyth-devel
> Error: Missing Dependency: libmyth-0.20.1.so.0 is needed by package
> libmyth-devel
> Error: Missing Dependency: libmythfreemheg-0.20.1.so.0 is needed by
> package libmyth-devel
> Error: Missing Dependency: libmyth = 0.20.1 is needed by package
> libmyth-devel
> Error: Missing Dependency: libmythlivemedia-0.20.1.so.0 is needed by
> package libmyth-devel
> Error: Missing Dependency: libmythui-0.20.1.so.0 is needed by package
> libmyth-devel
>
> I suspect I need to add another .repo file to /etc/yum.repos.d/. Here is
> what I presently have:
>
> /etc/yum.repos.d/atrpms.repo:enabled=1
> /etc/yum.repos.d/fedora-core.repo:enabled=1
> /etc/yum.repos.d/fedora-extras.repo:enabled=1
> /etc/yum.repos.d/fedora-updates.repo:enabled=1
> /etc/yum.repos.d/mythdora.repo:enabled=1
> /etc/yum.repos.d/mythdora.repo:enabled=1
>
> Only the stable in atrpms is enabled.
>
> If my guess is right, can anyone point me to a yum repo with the missing
> dependencies? If it's soething else, can I know what, please?

Try removing mythstream and libmyth-devel.

  rpm -e mythstream  libmyth-devel

I found it a good idea to make the update set smaller by deleting stuff. You 
can always re-install it later.

Cheers,
Remco



-- 
Remco Treffkorn (RT445)
HAM DC2XT
remco at rvt.com   (831) 685-1201



More information about the mythtv-users mailing list