[mythtv-users] Can't figure out s-video IN capturing with PVR-350

David George david at thegeorges.us
Wed Sep 5 16:32:38 UTC 2007


Replying to the parts I may be able to help with.

On 09/05/2007 11:18 AM, Daniel Arfsten wrote:
> I am very terribly lost. My main objective is to be able to record ALL 
> channels provided by my Time Warner Cable SA3250HD cable box. I first tried 
> firewire but when I tried to change the channel to a channel I wanted to 
> record, it just went back to the same station so I am guessing TWC has put 
> 5c encryption or blocked the firewire from working with video recording? So, 
> I would still like to use firewire for channel changing as I have read it's 
> more stable than ir-blaster. I will hook up s-video from cable box to 
> s-video IN  on the PVR-350 that I own, and rca plugs for audio to the audio 
> in on the pvr-350. I will just use the speakers connected to my pc to listen 
> to the audio from the recordings, is this ok? I will not really be using my 
> computer for watching live tv, mainly for scheduling recordings and that's 
> it. Although I have a XFX GF 6200 with dual head, vga out going to 17 flat 
> panel and the dvi out going to a 17" widescreen hdtv using a dvi to vga 
> adapter. I don't care that the sound will output thru my computer speakers.
>   
This should work.  Svideo and audio L/R is how I capture TV.
> What do I chose in the capture card section? MPEG-2 encoder or the V4L 
> thingyl? How can I test whether video is coming thru the s-video IN for the 
> PVR-350? I have all these inputs in /dev/video*
> crw-rw---- 1 root video 81,  0 2007-09-04 22:42 /dev/video0
> crw-rw---- 1 root video 81, 16 2007-09-04 22:42 /dev/video16
> crw-rw---- 1 root video 81, 24 2007-09-04 22:42 /dev/video24
> crw-rw---- 1 root video 81, 32 2007-09-04 22:42 /dev/video32
> crw-rw---- 1 root video 81, 48 2007-09-04 22:42 /dev/video48
> I tried doing cat /dev/video32 > foo.mpg but when  i played it back with 
> mplayer, it was just a bunch of garbled colored mess? What am I doing 
> wrong???
It should be setup as mpeg2 encoder (PVR-x50, PVR-500) in capture card.  
Try cat /dev/video0 > foo.mpg and playing back with mplayer.  
/dev/video0 is the MPEG2 output.
>  Also, I am trying to use this sa3250hd extrenal channel 
> change script here, will this work?
> http://bentonroberts.com/personal/media-server/code/sa3250ch-BR.c/view
>   
Someone else will need to help here.



More information about the mythtv-users mailing list