[mythtv-users] mplayer -dumpstream better than myth record

Ben bluey at iguanaworks.net
Fri Sep 14 00:02:07 UTC 2007


I have two channels that I can record perfectly with mplayer but not
with mythtv. Using the command

mplayer dvb://CHANNEL -dumpstream 

I can then play the file back with mplayer (or whatever) and it is
great. If instead, I have mythtv record the program, then when I play it
back it is missing a lot of frames and jumps around and sometimes cuts
on entirely. This happens if I play it back in mythtv-frontend or with
mplayer.

Since I'm doing the playback with the same program (mplayer) clearly,
the dump of the tv signal is different when recorded from mythtv than
mplayer. Why? And this is only true on some channels... for example, FOX
has this problem, but ABC and NBC do not. These are HDTV signals over
the air.

I have an air2pc card with 2.6.22 kernel (debian sid) and myth-0.20.2.
All the channels receive >80% signal using dtvsignal.  My first thought
was that mplayer was using a different frequency than mythtv was for the
channels. Looking at the mysql database, I see under 
mythconverg/dtv_multiplex/frequency that for the channel in question I'm
using the frequency 503000000 and mplayer (in .mplayer/channels.conf) is
using 503028615. So I changed the line in the sql database and restarted
mythtv, but that didn't make a difference. I undid that change and added
28615 to the mythconverg/channels/finetune but that too had no effect.
I'm stumped as to why saving the stream is different. Any ideas? Both
mplayer and myth are running as unprivileged users without suid or
anything. 

It goes without saying, but live TV of these channels with mythtv also
doesn't work well, but "mplayer dvb://CHANNEL" is fine. And finally, is
there a way to have mythtv-backend use mplayer to save recording and
just circumvent whatever problem this is?

Thanks,

Ben



More information about the mythtv-users mailing list