[mythtv-users] nvidia-graphics9755 for Fedora 7 and error reading repomd.xml

Jason McMillon jmcmillon at gmail.com
Sat Sep 15 18:30:01 UTC 2007


On 9/15/07, Kevin Clayton <kevin.clayton at gmail.com> wrote:
> I was on FC2 and a very old myth and wanted tv listings again
> so I did a fresh install of Fedora 7. And wanted to sort of follow Jarod's
> FC6 guide.
>
> I can't seem to get proper nvidia graphics drivers installed.
>
> I wonder if I have yum set up incorrectly and if I'm looking for the
> right nvidia drivers.
>
> My video card:
>     nVidia Corporation NV18 [GeForece4 MX 440 AGP 8x]
>
> Here's some kernel info:
>
>    [root at zion yum.repos.d]# yum list installed | grep kernel | sort
>    kernel-headers.i386                      2.6.21-1.3194.fc7      installed
>    kernel.i686                              2.6.21-1.3194.fc7       installed
>    [root at zion yum.repos.d]#
>    [root at zion yum.repos.d]# echo $KVER
>    2.6.21-1.3194.fc7                                           <----- my kernel version
>    [root at zion yum.repos.d]#
>
> Yum update gives error regarding repomd.xml:
>
>    [root at zion yum.repos.d]# yum install nvidia-graphics9755-kmdl-$KVER
>    Loading "installonlyn" plugin
>    Setting up Install Process
>    Parsing package install arguments
>    http://dl.atrpms.net/fc7-i386/atrpms/stable/repodata/repomd.xml: [Errno 14] HTTP Error 404: Date: Sat, 15 Sep 2007  15:13:29 GMT
>    Server: Apache/2.2.3 (Red Hat)
>    Content-Length: 319
>    Content-Type: text/html; charset=iso-8859-1
>
>    Trying other mirror.
>    Error: Cannot open/read repomd.xml file for repository: atrpms
>    [root at zion yum.repos.d]#
>
>
> If I go to the atrpms web page and look under Fedora 7 distribution, nvidia-graphics
> http://atrpms.net/dist/f7/nvidia-graphics/
> I don't find an entry for nvidia-graphics9755*, there are entries
> for nvidia-graphics100*
>
> I checked under FC6 on atrpms, and also, there are entries for nvidia-graphics100 but
> not nvidia-graphics9755
>
> Thanks for any suggestions.
> Kevin.
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>
>

To solve your repomd.xml you need to uncomment a line in your
/etc/yum.repos.d/atrpms.repo file.  Fedora Core dropped the Core from
their name so you should uncomment:
baseurl=http://dl.atrpms.net/f$releasever-$basearch/atrpms/stable

You also should use the nvidia-graphics100 drivers and not the older
9755 drivers listed on Jarod's website.

Hope it helps!!
Jason


More information about the mythtv-users mailing list