[mythtv-users] nvidia 6200 + 1080p

Rich West Rich.West at wesmo.com
Sun Sep 16 15:05:58 UTC 2007


Mitch Gore wrote:
> I am trying to connect my Optoma HD80 project to my Myth Box.  I have 
> a Nvidia 6200 that i am using a DVI-to-HDMI converter into the HDMI 
> port of the HD80. 
>
> Here is a copy of my xorg....
>
> [root at mythtv myth]# cat /etc/X11/xorg.conf
> # Xorg configuration created by system-config-display
>
> Section "ServerLayout"
>         Identifier     "single head configuration"
>         Screen      0  "Screen0" 0 0
>         InputDevice    "Keyboard0" "CoreKeyboard"
> EndSection
>
> Section "InputDevice"
>         Identifier  "Keyboard0"
>         Driver      "kbd"
>         Option      "XkbModel" "pc105"
>         Option      "XkbLayout" "us"
> EndSection
>
> Section "Device"
>         Identifier  "Videocard0"
>         Driver      "nv"
> EndSection
>
> Section "Screen"
>         Identifier "Screen0"
>         Device     "Videocard0"
>         DefaultDepth     24
>         SubSection "Display"
>                 Viewport   0 0
>                 Depth     24
>                 Modes    "1920x1080"
>         EndSubSection
> EndSection
>
> This works ok but its running the nv driver not nvidia binary.  When i 
> change the driver to nvidia the desktop will load but when mythtv 
> loads it crashes X.  glxgears also crashes X.  here is the mythFE log....
>
> [myth at mythtv ~]$ export DISPLAY=:0
> [myth at mythtv ~]$ mythfrontend
> 2007-09-14 20:46:51.240 Using runtime prefix = /usr/local
> 2007-09-14 20:46:51.246 DPMS is active.
> 2007-09-14 20:46:51.258 New DB connection, total: 1
> 2007-09-14 20:46:51.263 Connected to database 'mythconverg' at host: 
> localhost
> 2007-09-14 20:46:51.263 Total desktop dim: 1920x1080, with 1 screen[s].
> 2007-09-14 20:46:51.266 Using screen 0, 1920x1080 at 0,0
> 2007-09-14 20:46:51.279 Current Schema Version: 1195
> 2007-09-14 20:46:51.280 mythfrontend version: 0.21.20070820-1 
> www.mythtv.org <http://www.mythtv.org>
> 2007-09-14 20:46:51.280 Enabled verbose msgs:  important general
> 2007-09-14 20:46:51.374 The theme (blootube-osd) needs to be updated  
> to include a themeinfo.xml file
> 2007-09-14 20:46:51.386 The theme (classic) needs to be updated  to 
> include a themeinfo.xml file
> 2007-09-14 20:46: 51.387 The theme (DVR) needs to be updated  to 
> include a themeinfo.xml file
> 2007-09-14 20:46:51.563 Total desktop dim: 1920x1080, with 1 screen[s].
> 2007-09-14 20:46:51.564 Using screen 0, 1920x1080 at 0,0
> 2007-09-14 20:46: 51.567 Switching to wide mode (blootube-wide)
> mythfrontend: Fatal IO error: client killed
> Mutex destroy failure: Device or resource busy
>
>
> what is the deal?  I know my nvidia drivers are good because i used to 
> drive my projector with component out, 1080i. 
>
> running FC6
> uname -r
> 2.6.22.2-42.fc6
Have you tried the line :
Modes    "1920x1080_60"


That *should* give you 1080p using the nVidia drivers...

-Rich


More information about the mythtv-users mailing list