[mythtv-users] my experience "upgrading" from KnoppMyth to mythDora

Ryan Allen ryan at the-summit.net
Mon Sep 17 01:38:48 UTC 2007


Summary, nothing but trouble!!

I had a perfectly working KnoppMyth machine, and didn't change any
hardware.  I needed to upgrade for SchedulesDirect, and decided to try
mythDora for a change.


Issues I encountered:

1) Had to install in text mode.

The mythDora installer detected but couldn't use the nvidia graphics
card.  I had to use text install.  After that completed, the system
started in runlevel 3.  I had to do some google searches to figure out
how to start in RL 5.  The installer did report "found nvidia graphics
card.... starting graphical installer", then garbage appeared and the
system hung.


2) Playback is choppy.

After getting everything working, video playback is painfully choppy.
__VERY__ choppy.  It is HDTV, on an Athlon 4200+ and 2Gigs of ram.  I
have XvMC enabled.  CPU for live TV is running at about 60% (35% idol)
according to top.  I've iterated through as many settings as I can
find.  This is about the SAME CPU usage I had on previous KnoppMyth
(pre data direct TV change over version), but I had stellar TV
playback with knopymyth.


3) Front end crashes.

the front end has crashed for no apparent reason (nothing in the
logs) about 4 times during playback (not live TV) in the last 12
hours of tinkering.  

The nvidia drivers are current.
According to yum: nvidia-graphics9755.i386


5) Default video player has _issues_.

The default video player is xine.  When it launched, there was no sound,
(I had sound in recording playback).  The GUI window is on top
during playback and I couldn't figure out how to make it go away.  I
played with all the settings I could find.  I finally switched over
to mplayer (I'm more familiar with).  Mplayer's playback was very
choppy too.  Apparently, XvMC is not compiled into the mplayer that
is delivered with mythDora (no video message).  Also, it has no
sound.  AND, when I set the -fs flag (full screen), it only uses
about 25% of the screen :(



6) The screen saver is turned on??!!??

There seems to be a screen saver installed.  The screen blanks out
after about 15 minutes of use.  Hitting any key brings the screen back.
I still cannot find where the setting for this lives, and this is
unacceptable for a DVR system, obviously.



Wow, that is a lot of problems.  I'm downloading the latest KnoppMyth
now, hopefully to make all these problems go away!!!

I hope the mythDora guys read this and are aware of these issues, and
can address them in the next release!

I intend this to be more informative then critical, but from my
experience, mythDora needs some work!



-- 

+-----------------------------+
|     ryan at the-summit.net     |
|  http://www.the-summit.net  |
+-----------------------------+


More information about the mythtv-users mailing list