[mythtv-users] Problem tuning QAM with HDHR

Scott list-mythtv at bluecamel.eml.cc
Tue Sep 18 14:04:24 UTC 2007


I have an HDHR running the current 20070914 firmware and am using MythTV
fixes mythtv-0.20.2_p14498 on gentoo. I'm trying to setup QAM for TWC in
Raleigh/Durham for the first time. 

My problem is I see all the channels I want except for two channels on
the
same freuency. The problem is with channel 113.1 WTVD-DT ABC and channel
113.4 WRAZ-DT NBC. These two channels show up fine in the HDHR scan but
not
when MythTV does a scan. I have no problems with MythTV scanning and
tuning
other QAM channels.

When I do a scan with the HDHR I get the following for 113:

   SCANNING: 729000000 (us-cable:113, us-irc:113)
   LOCK: qam256 (ss=88 snq=88 seq=100)
   PROGRAM: 1: 0.0
   PROGRAM: 2: 0.0
   PROGRAM: 3: 0.0
   PROGRAM: 4: 0.0
   PROGRAM: 5: 0.0
   PROGRAM: 6: 0.0

When I scan from MythTV this frequency returns a timeout - "no tables"
error. From the mythtv-setup debug output:

   2007-09-18 08:54:09.242 SIScan(1010317c/1): \
   Transport Scan Item 'QAM-256 Channel 113' #113
      mplexid(-1) standard(atsc) sourceid(1)
      UseTimer(0) scanning(0)
      timeoutTune(1000 msec)
      frequency(729000000) modulation(5)
      offset[0..2]: 0 0 0

If I use hdhomerun_config I can tune to both of these channels and get
good
video and audio through vlc. Mythtv isn't picking them up in the scan
though.

Does anyone have any suggestion on how to get MythTV to pick up these
two
QAM channels?

Here's the debug output after I've tuned the HDHR to the 113.1:

   tun: ch=qam256:729000000 lock=qam256 ss=87 snq=87 seq=100
   dbg=22634-6944
   dev: resync=0 overflow=0
   ts:  bps=38809216 ut=92 te=0 miss=0 crc=0
   flt: bps=11027328
   net: pps=0 buferr=0 neterr=0 stop=0

--
Scott


More information about the mythtv-users mailing list