[mythtv-users] Broken scheduling in 0.20?

Michael T. Dean mtdean at thirdcontact.com
Mon Sep 24 20:28:17 UTC 2007


On 09/24/2007 02:53 PM, Lars Kellogg-Stedman wrote:
> I'm running MythTV from the latest KnoppMyth release:
>
> mythtv at tv:~$ mythbackend --version
> Library API version     : 0.20.20070821-1
> Source code version     : 14463M
> SVN Branch              : branches/release-0-20-fixes
>
> I was previously running 0.19.mumble on a Centos 4 system, which
> worked wonderfully.  With 0.20, everything seems to have gone smoothly
> -- TV out on my PVR-350 is working fine, I can watch live TV, I can
> browse schedules -- but I am unable to actually make any scheduled
> recordings.
>
> Running 'mythbackend --testched' prints out what looks like a
> perfectly reasonable list of scheduled recordings.  On the other hand,
> 'mythbackend --printsched' only works once -- immediately after
> starting mythbackend -- and otherwise always returns an empty list:
>
> Retrieving Schedule from Master backend.
> --- print list start ---
> Title - Subtitle                    Chan ChID Day Start  End   C I  T N   Pri
> ---  print list end  ---
>
> Looking at the "Upcoming Recordings" screen in either mythfrontend or
> mythweb shows nothing scheduled, but looking at the "recording
> schedules" in mythweb shows everything I expect to see.
>
> I'm not sure where else to start looking for solutions -- nothing in
> the mythbackend log looks especially relevant.  Has anyone encountered
> this problem before?  Or can you suggest some troubleshooting?
>
> On the odd chance that it matters, this system has three tuners --
> /dev/video0 is the PVR-350 and is *not* currently configured as a
> capture card.

If, by that, you mean you don't have the capture card defined in Myth,
that's not a problem.  If you mean you've defined the capture card in
Myth, but don't have any of its inputs connected to a video source, it
may not be a problem at this moment, but it will be (you'll later get
garbage into your configuration and have to do a...

>   /dev/video1 and /dev/video2 are two tuners on a PVR-500
> and are both connected to the same video source.

Delete all video sources...  Broken video sources, input connections,
and/or channels. 
http://www.gossamer-threads.com/lists/mythtv/users/264034#264034

Mike


More information about the mythtv-users mailing list