[mythtv-users] Bizarre commercial skip behaviour

DaveD mythtv at guiplot.com
Wed Apr 2 04:57:24 UTC 2008


This has happened a few times, now, since upgrading to 0.21 (I ran 0.21 
trunk version for some time without ever seeing it).  I have commercial 
flagging turned on but not auto-skip (not always reliable and I like 
having control).  While watching a show, I'll hit the skip button at the 
beginning of a commercial and it will jump to the stored position in a 
different, previously-watched show!  By "previously-watched" I mean in 
the same session; immediately before the one being watched.  Good news 
is that when I exit the show it jumps to, and go back to watching the 
show I was trying to watch, it picks up where it left off and I can fast 
forward from there.  If I try it again, it does the exact same thing, 
jumping to the exact same saved position in the same other show.  Again, 
it returns to where it left of when I restart the playback.  Today when 
it did it again, I tried playing the show again after it had finished 
and then commercial skipping worked normally.  In other words, the 
problem keeps happening as long as I'm playing a show.  Once the show 
has played to the end (all positions cleared?) it plays (and skips) 
normally.

As I said, it has done this a few times, now, but I don't know exactly 
what triggers it.  I'll try some combinations of 
show-watching/commercial-skipping and see if I can reproduce it.  I 
don't have any flagged shows stored right now, but that will change 
tomorrow.

DaveD.



More information about the mythtv-users mailing list