[mythtv-users] All encoder MPG stream buffers are full. Dropping data.

Billy Macdonald billymacdonald at gmail.com
Fri Apr 11 23:38:07 UTC 2008


On Wed, Apr 2, 2008 at 8:08 PM, Kelly Shutt <tetrahedron at whycomehere.com> wrote:
> I've been getting "All encoder MPG stream buffers are full. Dropping
>  data." for the last week or so and it's causing jitters in my
>  recording.  My machine has been running mythtv fine for over a year now
>  and started doing this after I updated to 2.6.24 kernel and the latest
>  0.21 mythtv release.  It worked fine with 2.6.23 kernel and 0.20
>  release, but not the updates.  I have started running the database
>  optimization script nightly, but that has not helped.  I have also added
>  "options ivtv enc_mpg_buffers=16" to make sure it's using the maximum
>  buffer size for the PVR-350 card, which did not help either.  I've been
>  looking at load, etc. and don't see any issues there.  The machine is
>  dedicated to MythTV only, so there's not really anything else running
>  that could interfere.  I've even discontinued all my transcoding for the
>  moment to eliminate that as a possible CPU hog.  Anyone have any other
>  suggestions?
>
>  Thanks,
>  Kelly Shutt
>
>

downgrade your kernel to 2.6.23 and see if that makes a difference.
When you upgraded your kernel, you probably got new IVTV drivers too.
Drop them both to the previous level and see if that helps.  Typically
the older kernel will still be there in grub when you reboot so it
should be a fairly easy test.

Good luck,
Billy


More information about the mythtv-users mailing list