[mythtv-users] VIDIOCMCAPTURE0: Device or resource busy

Chris Picton chrisp at tangent.co.za
Sat Aug 23 07:30:24 UTC 2008


On Sat, 2008-08-23 at 00:20 +0200, Xaero wrote:
> same problem
> see
> http://mythtv.org/pipermail/mythtv-users/2008-August/231432.html
> 
> which card are you using?

I have a Leadtek TV2000XP RM

I will try with an older kernel (currently I am using 2.6.26, but my
previous installation was 2.6.22)


> 
> 
> 2008/8/22 Chris Picton <chrisp at tangent.co.za>
>         Hi all
>         
>         I have just reinstalled my mythtv server after a hdd failure.
>          I am
>         using ebuild version 0.21_p18116
>         
>         I have kept my configs as simple as possible, but I am getting
>         the
>         following error when trying to watch live tv:
>         
>         2008-08-22 20:52:26.096 TVRec(1): Changing from None to
>         WatchingLiveTV
>         2008-08-22 20:52:26.102 TVRec(1): HW Tuner: 1->1
>         2008-08-22 20:52:27.251 AutoExpire: CalcParams(): Max required
>         Free
>         Space: 2.0 GB w/freq: 15 min
>         VIDIOCMCAPTUREi0: Device or resource busy
>         VIDIOCMCAPTUREi1: Device or resource busy
>         VIDIOCMCAPTURE0: Device or resource busy
>         VIDIOCMCAPTURE1: Device or resource busy
>         (last two lines continually repeated)
>         
>         I am reading from a bttv card, using the 'Television' input.
>         
>         The screen goes green, but I do get audio playing.
>         
>         I have tried playing the nuv file with mplayer, using many
>         different vo
>         options, but it also only plays me a green screen, so I dont
>         think it is
>         an output problem
>         
>         If I use tvtime on the same device (/dev/v4l/video0) , I get a
>         perfect
>         picture, so I assume it is not my capture card malfunctioning.
>         
>         If I try run tvtime while mythtv is on livetv, tvtime gives an
>         error
>         about device busy, so mythtv is locking the right card.
>         
>         I have just dropped my entire mythconverg database, and rerun
>         mythtv-setup, but I get the same problem.
>         
>         In addition, I removed v4l1, and v4l1 compatibility from the
>         kernel, and
>         I did not get any recording (black screen, no sound, not
>         responsive to
>         controls).  Should mythtv use v4l1 or v4l2 when talking to
>         analogue cards?
>         _______________________________________________
>         mythtv-users mailing list
>         mythtv-users at mythtv.org
>         http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> 
> 
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
---------------------+----------------------------------- 
        Chris Picton | Key ID: 9D28A988 (wwwkeys.pgp.net)
  Technical Director | PGP Key Fingerprint:
     Tangent Systems | 2B46 29EA D530 79EC D9EA
        011 447 8096 | 3ED0 229D 6DD6 9D28 A988
chrisp at tangent.co.za | www.tangent.co.za/keys/chrisp.asc
---------------------+-----------------------------------
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20080823/420ef982/attachment.pgp 


More information about the mythtv-users mailing list