[mythtv-users] ringbuf in memory?

Michael T. Dean mtdean at thirdcontact.com
Fri Dec 19 02:05:26 UTC 2008


On 12/18/2008 08:54 PM, Scott Harris wrote:
> Michael T. Dean wrote:
>   
>> It's far more likely your DB that's causing the "lag."  The stuttering 
>> and slow guide could be anything from choosing the wrong (=bob or any 
>> 2x) deinterlacer to missing channel icons to ... (narrowing it down is 
>> easier with specific and detailed descriptions of symptoms).
> I've tried all the different fixes to prevent the guide from 
> stuttering.  There are
> improvements to some aspects for different settings.  For instance, removing
> the icons from the DB table fixed the super slow guide,

Yes, it will be super slow if you have an icon specified that's 
non-existent, not readable, or in a directory that's not accessible by 
the user running the frontend.

>  but it still 
> suffers from
> random 3-10 second hangs in between key presses (not consistent, and irw
> shows the keys received)
>   

That sounds like an issue ( 
http://www.gossamer-threads.com/lists/mythtv/commits/356391#356391 ) 
that was fixed in 0.21-fixes in r19222 (2 weeks ago).  If you're running 
an earlier version of -fixes, you may want to see if there's an upgrade 
available.

> I have three different physical disks in this system and have tried the 
> DB on
> all of them.  I'm pretty certain that isn't the problem.  This is a 
> pretty beefy
> system: AMD Athlon(tm) 64 X2 Dual Core Processor 5600+ running
> 2.6.27.7-134.fc10.x86_64 with 6Gb of ram.
>
> Interesting enough, I've tweaked HD so that 1080p mkv files play back with
> less than .25.  This is with the coreavc stuff, but still, SD 
> live/recorded TV
> shouldn't be killing this system as much as it is with loads over 2.

Yeah, there's definitely a misconfiguration there--that system shouldn't 
even realize when you're watching LiveTV.  Again, though, I don't think 
it has anything to do with the reading/writing of the video.

Mike


More information about the mythtv-users mailing list