[mythtv-users] PVR-150 install issues with LIRC irblaster

Evuraan::ഏവൂരാന്‍ evuraan at gmail.com
Mon Jan 7 18:53:44 UTC 2008


It is assumed that you've lirc installed & configured to use pvr150.
This would create the file you were trying to modify.

You can check the file's permission,

ls -ltr /etc/lirc/hardware.conf

Then sudo to root to modify it

sudo -u
sed -i 's/^MODULES/#MODULES/g' /etc/lirc/hardware.conf
echo MODULES="lirc_pvr150" >> /etc/lirc/hardware.conf



Or, you can edit the file using gedit (assuming you've gedit installed)

sudo gedit /etc/lirc/hardware.conf

If using gedit, you need to replace line starting with

MODULES="....

with


MODULES="lirc_pvr150"


On Jan 7, 2008 1:14 PM, Paul <openletter at yahoo.com> wrote:
> Thank you very much.  However, I'm quite new to Linux
> so I'm basically just following instructions and can't
> understand everything just yet.
>
> I am stuck on step 4:
>
> Modify /etc/lirc/hardware.conf to call *only*
> lirc_pvr150
>
> # sed -i 's/^MODULES/#MODULES/g'
> /etc/lirc/hardware.conf
>
> # echo MODULES="lirc_pvr150" >>
> /etc/lirc/hardware.conf
>
> When I enter the second command, I get the following
> response:
>
> -bash: /etc/lirc/hardware.conf: Permission denied
>
> What does this mean?  I run it as sudo.
>
> Thanks!
>
> --- "Evuraan::ഏവൂരാന്"
>
> <evuraan at gmail.com> wrote:
>
> > I enabled the ir blaster on pvr 150 the other day.
> > I've documented steps here:
> >
> >
> http://evuraan.blogspot.com/2008/01/how-to-get-to-use-ir-transmitter-of-pvr.html
> >
> > I hope this helps.
> >
> > On Jan 5, 2008 3:07 PM, Paul <openletter at yahoo.com>
> > wrote:
> > > Hello-
> > >
> > > I'm trying to install LIRC for the irblaster on my
> > > PVR-150 on Ubuntu 7.10 using the community install
> > > guide (referenced in the MythTV install guide)
> > here:
> > > http://tinyurl.com/2uvshh
> > >
> > > I can follow it all pretty well, but when it
> > states to
> > > make the codes conform to how irw reports the
> > > keypress, I can't follow this step because I have
> > not
> > > configured a remote (as instructed in the MythTV
> > and
> > > lirc install guides).
> > >
> > > So I soldier on and restart lirc then run the
> > irsend
> > > test using a code from lircd.conf and and I get:
> > > irsend SEND_ONCE blaster 1_120_KEY_POWER
> > > irsend: could not connect to socket
> > > irsend: No such file or directory
> > >
> > > What am I doing wrong?
> > >
> > >
> > _______________________________________________
> > mythtv-users mailing list
> > mythtv-users at mythtv.org
> >
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> >
>
>
>
>       ____________________________________________________________________________________
> Looking for last minute shopping deals?
> Find them fast with Yahoo! Search.  http://tools.search.yahoo.com/newsearch/category.php?category=shopping
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>


More information about the mythtv-users mailing list