[mythtv-users] Remote control not working in MythWelcome after hibernate

Jan mpr.list at googlemail.com
Wed Jan 16 05:28:06 UTC 2008


On 1/15/08, Eduard Huguet <eduardhc at gmail.com> wrote:

> Hi,
>     I have the same card as you (Nova T-500) and I usually have the same
> issue. I suspect it's something related to the IR driver for this card,
> which is not properly restoring after a suspend / resume cycle. My solution
> was to add also 'lircd' and 'xdm' to the lists of services being stopped /
> started on suspending, so both the LIRC daemon and whole X (and thus
> MythFrontend) are restarted. In my case, restarting X was also a must, as
> sometimes resuming didn't work fine always othewise.
>
Well, restarting X works to get the remote back to live in
MythWelcome. This is only a dirty hack IMHO though, since the remote
would work in MythFrontend after hibernate anyway, only I could not
start the FE with the remote...

> Anyway, a final thought: your computer should wake up properly with ACPI
> either from suspending or from powering off, or simply not work on either
> case. I mean, both things are exactly the same from a pure hardware point of
> view (suspending IS a full power off, it's just the kernel who saves /
> restores the OS state).
>
> So if ACPI wakeup is working from resume but not from power-off then it's
> probably because your Linux is saving your "system" time into the BIOS when
> powering off (most Linux do that by default), and your BIOS doesn't like
> that (at least, mine doesn't like neither...).
>
> You'll probably have to edit the /etc/init.d/clockd script (or whatever is
> called in your distro) to save / restore the ACPI programmed time. Basically
> you must something like this:
>
>  search for the stop() function in /etc/init.d/clock script
>  add this line in the beginning of the function:
>
> ACPI=`cat /proc/acpi/alarm`
>
>  and this one at the end of the function:
>
> echo $ACPI > /proc/acpi/alarm
>
> This should solve your issue.
>
> Best regards,
>   Eduard
>

I have set up ACPI wake up according to the Ubuntu Wiki
https://help.ubuntu.com/community/MythTV/Install/WhatNext/ACPIWake
and I have done the changes to the hwclock.sh as mentioned there and
like you say. My hwclock.sh was a little different to the example on
the Ubuntu wiki though, so I am not sure if I have added the command
to set the acpi time properly.

Taking restarting X into consideration, a fresh boot will not be much
slower than resuming from hibernate anymore. If the system would wake
up from complete power off, I could as well use that and be safe that
everything will work...

Rock on,
Jan


More information about the mythtv-users mailing list