[mythtv-users] Remote control not working in MythWelcome after hibernate [Somewhat SOLVED]

Jan mpr.list at googlemail.com
Sat Jan 19 18:16:52 UTC 2008


Am Dienstag 15 Januar 2008 13:16:28 schrieb Eduard Huguet:


> Anyway, a final thought: your computer should wake up properly with ACPI
> either from suspending or from powering off, or simply not work on either
> case. I mean, both things are exactly the same from a pure hardware point
> of view (suspending IS a full power off, it's just the kernel who saves /
> restores the OS state).
>
> So if ACPI wakeup is working from resume but not from power-off then it's
> probably because your Linux is saving your "system" time into the BIOS when
> powering off (most Linux do that by default), and your BIOS doesn't like
> that (at least, mine doesn't like neither...).
>
> You'll probably have to edit the /etc/init.d/clockd script (or whatever is
> called in your distro) to save / restore the ACPI programmed time.
> Basically you must something like this:
>
>  search for the stop() function in /etc/init.d/clock script
>  add this line in the beginning of the function:
>
> ACPI=`cat /proc/acpi/alarm`
>
>  and this one at the end of the function:
>
> echo $ACPI > /proc/acpi/alarm
>
> This should solve your issue.
>
> Best regards,
>   Eduard

That made me dig a little deeper into the wakeup issue again and it turned out 
that my machine can indeed wake up from a complete power off. 
Setting the alarm after the hwclock gets set was already there, but in fact I 
need to use --directisa to have the clock being set properly.
Now I will revert from hibernate to halt and I hope that the remote will 
always be there in mythwelcome...

Thanks for the help everyone!

Rock on,
Jan


More information about the mythtv-users mailing list