[mythtv-users] ATTN: Users of XMLTV tv_grab_uk_rt grabber v0.5.50 with recent missing listings/errors

Paul Mason latepaul at gmail.com
Tue Jan 22 23:33:02 UTC 2008


On 22/01/2008, Nick Morrott <knowledgejunkie at gmail.com> wrote:
>
> On 21/01/2008, Paul Mason <latepaul at gmail.com> wrote:
> >
> >
> > On 20/01/2008, Nick Morrott <knowledgejunkie at gmail.com> wrote:
> > > Dear all,
> > >
> > > A very recent update to the tv_grab_uk_rt grabber in CVS is affecting
> > > the current 0.5.50 release version of the software.
> > >
> > > The update, which adds supports for natively timeshifted channel data,
> > > and support for channels on Freeview which do not broadcast all day
> > > (Virgin 1, UKTV History etc) is affecting how the current release
> > > version of the grabber parses the list of available channels
> > > (channel_ids) retrieved from the XMLTV.org supplement server. Signs of
> > > the problem may include missing listings for some channels, errors
> > > when running the grabber in non-quiet mode to retrieve listings or
> > > configure new channels.
> >
> >
> > Might this by why I've apparently got  recordings coming up on a channel
> > called "BBCLO"?  (looking at the details, which are otherwise correct,
> this
> > seems to be BBC2)
>
> You'd need to check the XMLTV ID for that channel in MythTV. There are
> no BBC channel names called "BBC*LO" configured in the grabber, so I'm
> not sure where that channel name has come from. Is this from DVB-T or
> a manually created channel? Can you still successfully tune to and
> record from that channel?



OK it wasn't due to a change in XMLTV.

Firstly I should say that I've got Myth displaying the channel callsign so
"BBCLO" is actually "BBC 1 London and South-east" (and BB2...)

The problem is one I've encountered before. I hit it again because I
re-installed my machine from scratch. I don't know how it's supposed to work
but when I come to run mythtv-setup it checks for xmltv grabbers installed,
finds them and asks me which I want to use, so I choose the UK RT one. It
then goes off and creates channels based on that. However I aborted that
part way through, because I wanted to create my channels via scanning -
which I do. Now I've got two sets of channels one which tunes ok but with no
xmltvids  (from the scanner) and one which have xmltvids but which can't
tune.

To fix this I used mythweb (cos it's easier) and update the xmltvids of the
tuneable channels based on the others (and the chanids file). I also made a
few other alterations (make some channels not visible, set use on air for
radio channels, change a few callsigns to make them display better)

Is this the way it's supposed to work? I'm sure I wasn't supposed to quit
out of the xmltv set up bit but still I can't see where it marries up the
grabber information with the tuning information (it hasn't got any has it?)
so that I don't get two sets of channels.

-- 
Paul Mason
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080122/0c1762b2/attachment.htm 


More information about the mythtv-users mailing list