[mythtv-users] MythArchive totally screwed up after update to 0.21

Torsten Crass torsten.crass at eBiology.de
Tue Jun 3 20:50:25 UTC 2008


Hi there,

anybody else having trouble using MythArchive after updating to 0.21? 
Currently, I am facing 3 different problems:


-------------------------------------------------------------------
1) Right after updating some weeks ago, mythburn *always* crashed with a 
message like "source file does not exist". No wonder, I'd say -- in line 
1765 of mythburn.py it now says

<code>
if file.attributes["type"].value == "recording":
         mediafile = file.attributes["filename"].value
     elif file.attributes["type"].value == "video":
         mediafile = os.path.join(videopath, 
file.attributes["filename"].value)
     elif file.attributes["type"].value == "file":
         mediafile = file.attributes["filename"].value
     else:
         fatalError("Unknown type of video file it must be 'recording', 
'video'

     if doesFileExist(mediafile) == False:
         fatalError("Source file does not exist: " + mediafile)
</code>

as opposed to line 1116 in the old 0.20 script:

<code>
if file.attributes["type"].value == "recording":
         mediafile = os.path.join(recordingpath, 
file.attributes["filename"].val
     elif file.attributes["type"].value == "video":
         mediafile = os.path.join(videopath, 
file.attributes["filename"].value)
     elif file.attributes["type"].value == "file":
         mediafile = file.attributes["filename"].value
     else:
         fatalError("Unknown type of video file it must be 'recording', 
'video'

     if doesFileExist(mediafile) == False:
         fatalError("Source file does not exist: " + mediafile)
</code>

Apparently the new script doesn't bother to prepend the recordings 
directory path to the recordings file, hence missing it. (Or am *I* 
missing something?)

(Unfortunately, a quick attempt to fix this didn't lead to ultimate 
success, either: in this case, the script just crashed a few processing 
steps later...)


-------------------------------------------------------------------
2) After upgrading to revision, uhm, I think it was 17435 from 
0.21-fixes on June 1st I couldn't even get past the target media 
selection screen (single / double layer DVD, plain file...). When 
hitting "next", the frontend reproducibly crashes. (Any ideas where to 
look for hints why it does so?)


-------------------------------------------------------------------
3) After repreatedly experiencing trouble with mplex (adding the "-M" 
options in the corresponding calls did occasionally help since this 
prevents mplex from trying to create multiple numbered output files when 
encountering a sequence end marker, which it obviously frequently did in 
German DVB-T streams...) I was really looking forward to the newly 
introduced option of reverting to ProjectX, which did a really good job 
in the old mythburn web interface. However, when I just tried to 
manually call mythburn.py in the recordings directory (to circumvent 
problem no 1), ProjectX eventually popped up its GUI, which it certainly 
wasn't supposed to do. Dunno if this has something to do with the

<code>
ini load error: java.io.FileNotFoundException: 
/var/mythtv/recordings/X.ini (No such file or directory)
</code>

reported a few lines after the initial call

<code>
projectx -id 0x1111,0x1112 -cut 
/var/mythtv/media/dvd/iso/work/1/cutlist_x.txt -out 
"/var/mythtv/media/dvd/iso/work/1" -name "1128_20080211205700" 
"1128_20080211205700.mpg"
</code>


------------------------------------------------------------------- 
Since my drive is slowly running full of recordings I'd like to archive, 
any helpful reply woud be greatly appreciated...

Regards --

	tcrass



More information about the mythtv-users mailing list