[mythtv-users] osx-packager doesn't build Qt?

scram69 scram69 at gmail.com
Tue Jun 10 05:06:45 UTC 2008


On Mon, Jun 9, 2008 at 12:02 PM, scram69 <scram69 at gmail.com> wrote:
> On Mon, Jun 9, 2008 at 8:52 AM, Asher <freedenizen at gmail.com> wrote:
>> On Mon, Jun 9, 2008 at 8:25 AM, David Snider <dsnider at thesniderpad.com> wrote:
>>> It always builds QT for me.   I have seen the "Threaded QT" messages on
>>> occasion, but they generally fixed themselves.  Have you tried a
>>> different rev than trunk?
>>
>> Ya, I would suggest using .21-fixes rather then trunk.  Trunk fails
>> for me due to Qt problems on 10.5 but 21-fixes is fine.
>
> I ran "osx-packager.pl -svnbranch release-0-21-fixes" and it gave me
> the threaded Qt error.  Is that the correct way to specify the fixes
> branch?
>
> As far as the Qt errors fixing themselves, is there a way to force the
> compilation to continue?
>

After much searching, I found the source of the error in the script
./src/myth-svn/mythtv/configure:
has_library libqt-mt ||
    die "ERROR! You must have a threaded Qt installed to compile MythTV."

So I commented out those two lines and ran osx-packager again.  It
failed on the very next two lines:
enabled lamemp3 && has_library libmp3lame && has_header lame/lame.h ||
    die "ERROR! You must have the Lame MP3 encoding library installed
to compile MythTV."

Now the ./build/lib/ directory is chock full of files like
libmp3lame*.dylib and libQt*.dylib, so I must be doing something very
basic wrong.
I install Xcode tools, and i download and run the osx-packager script.
 What else am I missing?


More information about the mythtv-users mailing list