[mythtv-users] Pinnacle PCTV HD Card

Tom Haddon tom at haddons.net
Fri Jun 20 23:47:16 UTC 2008


On Fri, 2008-06-20 at 16:24 -0700, J. Addington wrote:
> It's probably not the same problem but I recently installed this card and was having a problem with the v4l-dvb drivers.  There are several branches where you can download a kernel module source and compile but I just ended up upgrading my entire kernel to the latest stable version and the included 4dl-dvb drivers then worked fine.

I think you might be onto the right track here. I recompiled the v4l-dvb
modules and now I'm able to run:

scan 
/usr/share/doc/dvb-utils/examples/scan/atsc/us-ATSC-center-frequencies-8VSB > channels.conf 

Previously I was getting errors telling me the
device /dev/dvb/adapter0/frontend0 didn't exist, so I think I was
looking at a kernel/kernel module issue.

However, I get the following when I run the scan command:

mthaddon at sentinel:~$
scan /usr/share/doc/dvb-utils/examples/scan/atsc/us-ATSC-center-frequencies-8VSB > channels.conf
scanning /usr/share/doc/dvb-utils/examples/scan/atsc/us-ATSC-center-frequencies-8VSB
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
>>> tune to: 57028615:8VSB
WARNING: >>> tuning failed!!!
>>> tune to: 57028615:8VSB (tuning failed)
WARNING: >>> tuning failed!!!
>>> tune to: 63028615:8VSB
WARNING: >>> tuning failed!!!
>>> tune to: 63028615:8VSB (tuning failed)
WARNING: >>> tuning failed!!!
>>> tune to: 69028615:8VSB
WARNING: >>> tuning failed!!!
[...]
ERROR: initial tuning failed
dumping lists (0 services)
Done.


All the channels seem to fail this way, and I'm left with an empty
channels.conf. Doesn't seem good :(

Thanks, Tom

> 
> 
> ----- Original Message ----
> From: Tom Haddon <tom at haddons.net>
> To: mythtv-users at mythtv.org
> Sent: Friday, June 20, 2008 4:41:54 PM
> Subject: [mythtv-users] Pinnacle PCTV HD Card
> 
> Hi Folks,
> 
> I've just bought a Pinnacle PCTV HD Card as per
> http://www.bestbuy.com/site/olspage.jsp?skuId=8512424&type=product&id=1186005934822 and I'm trying to configure it to worth with my hardy Mythbuntu install.
> 
> I've been following the instructions on
> http://mythtv.org/wiki/index.php/Pinnacle_PCTV_HD_Card_(800i) and have
> extracted the firmware, and compiled the v4l-dvb drivers per that page.
> I'm then able to see the device as an option in mythtvsetup. I've
> configured it as an MPEG-2 encoder card, and in the "Probed Info"
> section it's showing "Pinnacle PCTV HD800i [cx8800]". I've then setup
> Schedules Direct as a Video Source, and under "Input Connections" I've
> defined "[MPEG: /dev/video0] (Television) -> Schedules Direct". I've
> then performed the "Scan for Channels" and have got a bunch of channels
> showing up (I'm just using rabbit ears, don't have cable or satellite),
> but when I go to "Watch TV" on the mythfrontend I get a blank screen for
> a few seconds and then I'm returned to the main menu. I see the
> following in the frontend log:
> 
> 2008-06-07 09:28:57.828 TV: Attempting to change from None to
> WatchingLiveTV
> 2008-06-07 09:28:57.829 Using protocol version 40
> 2008-06-07 09:29:03.102 GetEntryAt(-1) failed.
> 2008-06-07 09:29:03.103 EntryToProgram(0 at Wed Dec 31 16:00:00 1969)
> failed to get pginfo
> 2008-06-07 09:29:03.103 TV Error: LiveTV not successfully started
> 2008-06-07 09:29:03.138 TV Error: LiveTV not successfully started
> 2008-06-07 09:29:03.234 TV: Deleting TV Chain in destructor
> 2008-06-07 09:29:03.238 DPMS Deactivated
> 2008-06-07 09:29:03.238 DPMS Reactivated.
> 
> Also, after a recent update to linux-restricted-modules, whenever I run
> the mythtv-setup script and try to go to any of the pages (General,
> Capture Cards, Video Source, etc.) I get a message saying "If this is
> the master backend server, please run mythfilldatabase to populate the
> database with channel information". The only option is "OK" at which
> point mythtv-setup exits and I'm asked to run that mythfilldatabase. If
> I do, it runs fine, but still I get the same message when I re-run
> mythtv-setup. So now I can't see my current config, or change it in any
> way...
> 
> Any help appreciated.
> 
> Thanks, Tom
> 
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> 
> 
> 
>       
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users



More information about the mythtv-users mailing list