[mythtv-users] Problems with mythweather

Jeremy Young jeremyrainman at yahoo.com
Mon Jun 23 15:39:02 UTC 2008


Ok, I found a new repository (with a package that apparently has all the required perl dependencies). I uninstalled mythweather, cleaned out the database as you instructed, and re-installed from the new repository. I can now set up screens. I've set up three screens with no problems. Incidentally the location search function seems to work well if you use airport codes. Now when I pop into the weather screen from the main information menu, I still get a blank formatted screen. One large box and no text or images on the screen. It just sits there like that until I exit out. 

I looked in .../.mythtv/MythWeather and see that the retrieval scripts put nothing in those directories, even though the log (below) implies that it should have. I ran the scripts manually, and animaps.pl and ndfd.pl worked perfectly, throwing files in those directories. However, nwsxml.pl did not put any information in that directory and it didn't show any errors either. It does, however, dump some weather information to the terminal as it is running.

Even with information in those two directories from a manual script run, the weather screen on the front end is blank.

The frontend log shows this:

2008-06-23 07:59:05.106 Starting update of NWS-XML
2008-06-23 07:59:05.111 Starting update of NDFD-6_day
2008-06-23 07:59:05.119 Starting update of Animated-Map-Download
2008-06-23 07:59:05.518 nice /usr/share/mythtv/mythweather/scripts/us_nws/nwsxml.pl -u ENG -d /home/jeremy/.mythtv/MythWeather/NWS-XML KLGB has exited
2008-06-23 07:59:06.376 nice /usr/share/mythtv/mythweather/scripts/us_nws/animaps.pl -u ENG -d /home/jeremy/.mythtv/MythWeather/Animated-Map-Download http://images.weather.com/looper/archive/sw_vis_sat_720x486/ has exited
2008-06-23 07:59:07.473 nice /usr/share/mythtv/mythweather/scripts/us_nws/ndfd.pl -u ENG -d /home/jeremy/.mythtv/MythWeather/NDFD-6_day +33.48,-118.08 has exited
2008-06-23 07:59:09.717 XMLParse::LoadTheme using /usr/share/mythtv/themes/default/weather-ui.xml
2008-06-23 07:59:10.167 appt
2008-06-23 07:59:10.167 weather_icon
2008-06-23 07:59:10.167 wind_spdgst
2008-06-23 07:59:10.616 date-0
2008-06-23 07:59:10.616 date-1
2008-06-23 07:59:10.616 date-2
2008-06-23 07:59:10.616 date-3
2008-06-23 07:59:10.616 date-4
2008-06-23 07:59:10.616 date-5
2008-06-23 07:59:10.616 high-0
2008-06-23 07:59:10.616 high-1
2008-06-23 07:59:10.616 high-2
2008-06-23 07:59:10.616 high-3
2008-06-23 07:59:10.616 high-4
2008-06-23 07:59:10.616 high-5
2008-06-23 07:59:10.616 icon-0
2008-06-23 07:59:10.616 icon-1
2008-06-23 07:59:10.616 icon-2
2008-06-23 07:59:10.616 icon-3
2008-06-23 07:59:10.616 icon-4
2008-06-23 07:59:10.617 icon-5
2008-06-23 07:59:10.617 low-0
2008-06-23 07:59:10.617 low-1
2008-06-23 07:59:10.617 low-2
2008-06-23 07:59:10.617 low-3
2008-06-23 07:59:10.617 low-4
2008-06-23 07:59:10.617 low-5
2008-06-23 07:59:10.617 updatetime
2008-06-23 07:59:10.617 animatedimage
2008-06-23 07:59:10.617 updatetime




----- Original Message ----
From: Joe Ripley <vitaminjoe at gmail.com>
To: Discussion about mythtv <mythtv-users at mythtv.org>
Sent: Sunday, June 22, 2008 8:20:29 PM
Subject: Re: [mythtv-users] Problems with mythweather

On Sun, Jun 22, 2008 at 12:46 PM, Jeremy Young <jeremyrainman at yahoo.com> wrote:
> Well, that did something, it reset everything. Now when I go to the
> mythweather screen-setup screen, I am essentially back where I started when
> I first installed mythweather after the upgrade to 0.21. The screen setup
> screen lists no inactive screens, and no active screens, and the box on the
> right side of the screen has nothing in it.

Interesting... MythWeather should re-create all of the tables for you
and re-create the WeatherDBSchemaVer value in the 'settings' table.

Make sure that all your grabber scripts are working properly.  You can
test them by running them manually as the user mythfrontend usually
runs under.  If you get no errors, proceed to reset the DB tables
again.

Just as a re-cap, to completely reset the MythWeather table structure,
do this (assuming default DB user/password):

$ mysql -u mythtv -pmythtv mythconverg
mysql> delete from settings where value='WeatherDBSchemaVer';
mysql> drop table weatherdatalayout;
mysql> drop table weatherscreens;
mysql> drop table weathersourcesettings;

After this, restart the mythfrontend process and open the Weather
settings page.  The plugin will rebuild the DB tables and you should
be able to add screens.  For information on how to search for
locations, refer to the wiki page
(http://www.mythtv.org/wiki/index.php/MythWeather#Sources)

-- 
Joe Ripley
vitaminjoe at gmail.com
_______________________________________________
mythtv-users mailing list
mythtv-users at mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users



      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080623/f099c092/attachment-0001.htm 


More information about the mythtv-users mailing list