[mythtv-users] uPNP sources wrong IP address

Michael T. Dean mtdean at thirdcontact.com
Tue Jun 24 19:34:44 UTC 2008


On 06/24/2008 02:59 PM, Blammo wrote:
> On Tue, Jun 24, 2008 at 11:30 AM, Michael T. Dean wrote:
>   
>> On 06/24/2008 02:25 PM, Blammo wrote:
>>     
>>> Trying to make uPNP work with a Vista desktop.. The MBE shows up as
>>> having videos to share, has all the right filenames, media descipt
>>> data, etc, but when I actually go to watch one, windows media player
>>> says it can't open the URL.
>>>
>>> Upon examining the URL its' being fed, it's the IP address of the
>>> Tuners box (SBE) not the MBE. I've looked at all the uPNP config I can
>>> find, and can't see what might be wrong.
>>>       
>> That's correct, assuming that the show was recorded by the slave backend.
>>     
> Why? I would assume if I was browsing the SBE via uPNP I'd get files
> from that box. I don't expect the MBE to point me somewhere else, when
> the files are stored on the MBE. Can I override that behavior?

What do you have for the mythtv-setup setting:

Master Backend Override
If enabled, the master backend will stream and delete files if it finds 
them in the video directory. Useful if you are using a central storage 
location, like a NFS share, and your slave backend isn't running.

I don't know if it works with UPnP, but that's the closest thing we have 
to what you think you want.

>  The SBE
> has no horsepower, and is only a tuner box. Not where I want to stream
> files.
>   

But, as Greg said, it takes no effort to serve the file.

Mike


More information about the mythtv-users mailing list