[mythtv-users] OSX: Video display is zoomed despite settings.

TJ Harris tjharris at weaselworkz.com
Thu Jun 26 05:12:14 UTC 2008


On Mon, Jun 23, 2008 at 10:18 PM, TJ Harris <tjharris at weaselworkz.com> wrote:
> On Mon, Jun 23, 2008 at 9:11 PM, scram69 <scram69 at gmail.com> wrote:
>> On Mon, Jun 23, 2008 at 6:50 PM, TJ Harris <tjharris at weaselworkz.com> wrote:
>>> I have an odd problem on my Mac Mini, Mac OS X 0.21-fixes, frontend.
>>> The HD video plays back somewhat zoomed in, and I can't figure out why
>>> or how to fix it.   The effect is that occasionally scenes will look
>>> strange, or part of a person will be hidden because of the zoom.
>>> Otherwise, it's just the station logo that gets cut off.
>>>
>>> I checked all the overscan and zoom settings, then I reset the
>>> settings on my Mini (changed the frontend name) and started from
>>> scratch, but the problem persisted despite the clean settings.     I
>>> also ran Myth Frontend on my MacBook Pro, and it didnt have the issue
>>> at all there,  so it's not a source video problem.

I just grabbed the latest 0.21-fixes from svn, and it is now displaying fine.
I guess my previous version must have been one from early in the release cycle.

I built it via osx-packager.pl,  and it didn't require any special
patching to get MMX working.  I'm using the latest iPhone SDK,  gcc
version 4.0.1 (Apple Computer, Inc. build 5250).    With this build,
my CPU usage is as low as ever.  With previous builds
 I struggled to get the same performance as with 0.20.   Now, I can do
1080i HD playback with commflag running on my Core Duo 1.66GHz Mini.

>>>
>>> The display is a 720p LCD panel, connected via DVI.
>>>
>>> Has anyone else run into similar issues and have some suggestions for
>>> settings to tweak?
>>
>> I have an OSX mini connected to a 720p flat screen (DVI->HDMI) and can
>> view HD without a problem.  What resolution does your Mac report for
>> the LCD?
>
> Yeah, I agree it's capable of displaying fine.  I have run Myth
> frontend on the Mini for quite a while and it was fine in the past.
> It was around the 0.21 upgrade time that I started getting this.
>
> The mac sees it as 1280x720, and myth is set for 16:9.
>
> I played a couple HD files with VLC and XBMP OSX, and both displayed correctly.
>
>> I guess I'd have to agree - it sounds like it may be a setting on the
>> LCD.  I'm assuming the MBP was not connected to the LCD for playback.
>> What happens if you try to use the MBP connected to the TV?
>>
>> Oh- I'm running 0.21, not fixes, as I can't find a working OSX binary
>> for 0.21-fixes.  I'm assuming you compiled MythFrotend yourself?
>
> Yes, I compiled it with the osx-packager.pl script (after applying
> patches to re-enable MMX)
>


More information about the mythtv-users mailing list