[mythtv-users] Upgrade risk assessment

Scott Traurig straurig at comcast.net
Tue Oct 14 23:49:19 UTC 2008


Environment: ubuntu 7.10, mythtv 0.22 build 16578 (13 Mar 08)

My "production machine", i.e. the machine that my wife will kick my ass if
it doesn't remain completely stable, has recently ended 154 days of
fabulously stable uptime and finally required a reboot.

After the mandatory ass-kicking :-) I took advantage of the situation to, at
no small risk, to apply the 100+ pending updates to ubuntu 7.10. As luck
would have it everything appears to have turned out well.

Now the million dollar question is: should I go ahead and let the Update
Manager update the machine to ubuntu 8.04? I've heard that going to 8.04
(Hardy) requires 0.22. The build of 0.22 I'm running pre-dates the QT4
dependency. It would seem I'm in a good position to go forward.

That said of course I am flirting with breaking the "If it ain't broke..."
rule. Nevertheless does anyone have any experience or guidance with this
transition? Your tales of success or failure would be most appreciated.

Thanks,

Scott



More information about the mythtv-users mailing list