[mythtv-users] Does .22 fix the no mono output via spdif bug that's in .21 fixes?

Glenn Sommer glemsom at gmail.com
Fri Apr 24 08:01:40 UTC 2009


afaik the workaround in http://svn.mythtv.org/trac/ticket/5598 is
re-mixing everything to stereo on the spdif device.
Doing this WILL make mono audio streams work (since they're upsampled
to stereo). But it will also downsample all 5.1 streams to stereo.
(Please, correct me if I'm wrong here)
I don't think thats what you want if you're using AC-3 passthrough -
since you're losing your surround sound then.

2009/4/24 Allan Stirling <dibblah.allan.stirling at googlemail.com>:
> Another Sillyname wrote:
>>
>> 2009/4/23 Michael T. Dean <mtdean at thirdcontact.com>:
>>>
>>> On 04/23/2009 03:24 PM, Glenn Sommer wrote:
>>>>
>>>> 2009/4/23 Michael T. Dean:
>>>>
>>>>> On 04/23/2009 12:23 PM, Another Sillyname wrote:
>>>>>
>>>>>> As subject....Thanks in advance
>>>>>>
>>>>> TTBOMK, no.  You have to use your ALSA conf to fix it.
>>>>
>>>> Afaik the only workaround is to disable AC-3 passthrough.
>>>> I don't know if it's possible to say something like:
>>>> if channels < 2 then disable passthrough and re-encode/upsample to
>>>> stereo.
>>>
>>> Ah, yeah, with passthrough, you couldn't do anything about it (save buy a
>>> new receiver?).  Didn't realize there were problems with mono AC-3 (or
>>> DTS?)
>>> streams.
>>>
>>> Mike
>>> _______________________________________________
>>> mythtv-users mailing list
>>> mythtv-users at mythtv.org
>>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>>>
>>
>> Guys
>>
>> Thanks for the responses but this is a myth bug rather then a sound
>> server bug...
>>
>> If I record a mono source and play it back via myth then no sound (all
>> stereo and AC3 passthroughs work correctly as advertised).
>>
>> If I playback that source material using VLC it plays back fine no
>> matter what the sound source is (mono, stereo or AC3).
>>
>> I'm loath to start messing around with the alsa settings that may well
>> then break something later.......how do I make a request for this to
>> be addressed before .22 release?
>>
>
> By fixing it yourself, essentially.
>
> Please try the workaround listed in http://svn.mythtv.org/trac/ticket/5598
>
> Also the patch on the linked ticket. Does the error message change with the
> patch applied? (trunk only, backup first...)
>
> Cheers,
>
> Allan.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>


More information about the mythtv-users mailing list