[mythtv-users] VDPAU package problems 0.22?

Mike Dent mcdent at gmail.com
Fri Dec 4 22:27:33 UTC 2009


Hi,
On my frontend, a Acer Revo R3610 running mythbuntu 9.10, and myth
0.22 etc, I enabled VDPAU, pretty sure I followed these instructions
here:-
http://www.avenard.org/media/Ubuntu_Repository/Entries/2009/11/9_Karmic_and_Using_Avenard_repo.html
which seemed to work.
At some point after that I attempted to upgrade with apt-get upgrade
etc, then I ran in to a dependency problem. Now when I try and upgrade
I get the following error:

 apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run ‚apt-get -f install‚ to correct these.
The following packages have unmet dependencies.
  libmyth-0.22-0: Depends: libvdpau1 (>= 0.3) but it is not installed
  mplayer: Depends: libvdpau1 (>= 0.3) but it is not installed
E: Unmet dependencies. Try using -f.



And it I try apt-get upgrade -f


 apt-get upgrade -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies...Done
The following NEW packages will be installed
  libvdpau1
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
11 not fully installed or removed.
Need to get 0B/27.6kB of archives.
After this operation, 127kB of additional disk space will be used.
Do you want to continue [Y/n]?
(Reading database ... 103328 files and directories currently installed.)
Unpacking libvdpau1 (from .../libvdpau1_0.3-0ubuntu3_amd64.deb) ...
dpkg: error processing
/var/cache/apt/archives/libvdpau1_0.3-0ubuntu3_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/libvdpau.so.1', which is also in
package nvidia-185-libvdpau 0:185.18.36-0ubuntu9
Errors were encountered while processing:
 /var/cache/apt/archives/libvdpau1_0.3-0ubuntu3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Has anybody come across this? Or have a suggestion how to fix?

Thanks

Mike


More information about the mythtv-users mailing list