[mythtv-users] Error MythMusic compile

Romont Sylvain psgman24 at yahoo.fr
Sat Dec 5 14:03:01 UTC 2009


Hello!
I'm during to compile MythPlugin 0.22
I have all the prerequisites install
so I run ./configure and I have:
-------START--------------
Configuration settings:

        qmake          /usr/bin/qmake

        MythArchive    plugin will be built
        MythBrowser    plugin will be built
        MythGallery    plugin will be built
        MythGame       plugin will be built
        MythMusic      plugin will be built
        MythNews       plugin will be built
        MythVideo      plugin will be built
        MythWeather    plugin will be built
        MythZoneMinder plugin will not be built
        MythMovies     plugin will be built
        OpenGL         support will be included in MythGallery
        EXIF           support will be included in MythGallery
        OpenGL         support will be included in MythMusic
        libvisual      support will be included in MythMusic
        FFTW v.3       support will be included in MythMusic
        SDL            support will be included in MythMusic
------------END----------------
so all is ok (I don't want MythZoneMinder)
so I run make, and after few minutes I have an error in MythMusic, I have:
-------------START-------------
g++ -c -pipe -march=k8 -I/usr/include/directfb -D_REENTRANT -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -funit-at-a-time -D__STDC_CONSTANT_MACROS -fomit-frame-pointer -O3 -fomit-frame-pointer -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -D_REENTRANT -Wall -W -DPIC -fPIC -D_GNU_SOURCE -DPREFIX="/usr" -DMMX -D_FILE_OFFSET_BITS=64 -DQT_NO_DEBUG -DQT_PLUGIN -DQT_QT3SUPPORT_LIB -DQT3_SUPPORT -DQT_SQL_LIB -DQT_XML_LIB -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/lib/qt4/mkspecs/linux-g++ -I. -I/usr/lib/qt4/include/QtCore -I/usr/lib/qt4/include/QtNetwork -I/usr/lib/qt4/include/QtGui -I/usr/lib/qt4/include/QtOpenGL -I/usr/lib/qt4/include/QtXml -I/usr/lib/qt4/include/QtSql -I/usr/lib/qt4/include/Qt3Support -I/usr/lib/qt4/include -I/usr/include -I/usr/include -I/usr -I/usr/include -I/usr/include/mythtv -I/usr/include/mythtv/libmythdb -I/usr/include/mythtv/libmythui -I/usr/include/mythtv/libmyth
 -I/usr/include/libvisual-0.4 -I/usr/include/taglib -I/usr/include/cdda -I/usr/include -I. -o cddecoder.o cddecoder.cpp
In file included from cddecoder.h:15,
                 from cddecoder.cpp:22:
/usr/local/include/cdda_interface.h:87: erreur: expected unqualified-id before ‘private’
/usr/local/include/cdda_interface.h:87: erreur: expected ‘;’ before ‘private’
make[2]: *** [cddecoder.o] Erreur 1
make[2]: quittant le répertoire « /usr/local/mythtv/mythplugins/mythmusic/mythmusic »
make[1]: *** [sub-mythmusic-make_default] Erreur 2
make[1]: quittant le répertoire « /usr/local/mythtv/mythplugins/mythmusic »
make: *** [sub-mythmusic-make_default] Erreur 2
---------------END-----------------

Somebody can help me? I don't know why I have this error and I found nothing in Internet...

Thank you for your help!


      


More information about the mythtv-users mailing list