[mythtv-users] Can`t make lirc work in Mythbuntu karmic / 0.22

Marius Schrecker marius at schrecker.org
Sun Dec 6 08:55:51 UTC 2009


>
>On Sat, Dec 5, 2009 at 10:06 AM, Marius Schrecker <marius at schrecker.org> wrote:
>>Hi,
>>
>> I`m using a remote (harmony) based on the codes from a remotec bw6130 (usb with no additional lirc modules). Previously this put a hiddev0 file in /dev/usb/, and I pointed my hardware.conf at that. Everything worked. In Karmic the only new file I >>see under /dev is /dev/hidraw6. /dev/usb/hiddev0 looks like it`s the file for my keyboard, and is the only file under /dev/usb.
>>
>>
>>Here`s my lsusb output for the device:
>>
>>$ lsusb
>>Bus 002 Device 007: ID 0ad1:17f2 Remotec Technology, Ltd
>>
>>and dmesg when I plug it in:
>>
>>usb 2-1: new low speed USB device using ohci_hcd and address 8
>>[61472.449985] usb 2-1: configuration #1 chosen from 1 choice
>>[61472.466097] generic-usb 0003:0AD1:17F2.000D: hiddev96,hidraw6: USB HID v1.00 Device [Remotec Multimedia Master Receiver] on usb-0000:00:02.0-1/input0
>>
>>My hardware.conf file:
>># /etc/lirc/hardware.conf
>>#
>>#Chosen Remote Control
>>REMOTE="Remotec Multimedia PC Remote BW6130"
>>REMOTE_MODULES=""
>>REMOTE_DRIVER="bw6130"
>>REMOTE_DEVICE=""
>>REMOTE_SOCKET=""
>>REMOTE_LIRCD_CONF="remotec/lircd.conf.BW6130"
>>REMOTE_LIRCD_ARGS=""
>>
>>#Chosen IR Transmitter
>>TRANSMITTER="None"
>>TRANSMITTER_MODULES=""
>>TRANSMITTER_DRIVER=""
>>TRANSMITTER_DEVICE=""
>>TRANSMITTER_SOCKET=""
>>TRANSMITTER_LIRCD_CONF=""
>>TRANSMITTER_LIRCD_ARGS=""
>>
>>#Enable lircd
>>START_LIRCD="true"
>>
>>irw connects but gives no output
>>
>>
>>Any help would be appreciated :-)
>>Cheers!
>>
>>Marius
>>
>> 
>>_______________________________________________
>>mythtv-users mailing list
>>mythtv-users at mythtv.org
>>http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>>
>>

>On Sat Dec  5 16:41 , Michael Tiller <michael.tiller at gmail.com> wrote:
>As odd as this is going to sound, I couldn't get LIRC to work either until...wait for it...I turned off the media monitor.  I know this sounds crazy, but I worked on this for a few hours and when consulting the newsgroup somebody else mentioned this >media monitor issue.  I thought...inconceivable!  But it was true.  I'm not saying it will solve your problem (e.g. I was able to get data from irw) but it is something to keep in mind.
>--Mike

Thanks Mke,

 Didn't work for me, yet, but it certainly might be useful once I get some output from irw.

My buest guess is it's a udev issue, maybe I need a special rule to get the /dev nodes created, but I find it odd that irw connects at-all.


The wife is back from holiday, so quality time with the pc is, again, limited :-s

Cheers!

Marius


More information about the mythtv-users mailing list