[mythtv-users] What would cause "crackling" audio in some video playback

Michael T. Dean mtdean at thirdcontact.com
Mon Dec 7 22:37:42 UTC 2009


On 12/07/2009 09:17 AM, Dave Richardson wrote:
> Was showing off my mythtv system over the weekend and some videos
> unexpectedly had some crackling in the audio playback.  I didn't take
> inventory of which videos by file type or codec detail had the issue but I
> know that they were not from TV shows that myth had recorded.  Others
> played fine.  The ones that crackled weren't particularly intense audio
> passages nor was the video hi-end HD.
>
> Since my kit is SPDIF/Alsa audio, I could only think of a few reasons and
> would appreciate some tips...
>
> 1) Heat in the FE messing with the works
> 2) The files themselves actually have the crackling embedded (will be
> checking with my Windows laptop tonight)
> 3) The codecs for selected audio/video are interpreting a channel in a way
> that leads to crackling - or the myth audio upsampling code was
> introducing this crackling (how would I figure this out?)
>
> I wasn't playing at particularly loud levels so I'm not thinking I taxed
> the receiver or speakers to any measure.
>
> Is is possible that an SDPIF cable could have a flaw that would lead to
> such a thing?  Doesn't seem possible.

Extra audio buffering
Enable this setting if MythTV is playing "crackly" audio.  This setting 
affects digital tuners (QAM/DVB/ATSC) and hardware encoders.  It will 
have no effect on framegrabbers (MPEG-4/RTJPEG).  MythTV will keep extra 
audio data in its internal buffers to workaround this bug.

(which, BTW, is enabled by default).

Mike



More information about the mythtv-users mailing list