[mythtv-users] No card showup in new myth 0.22 fc12 fresh install

Claude Gélinas claude at phyto.qc.ca
Wed Dec 9 01:35:58 UTC 2009


fresh fc12 install
myth from svn
I have one pvr 500 and one HVR-1600 they look ok in dmesg but none are 
detected in mythtv-setup

I've tested my card with cat /dev/video0 > /tmp/test_capture.mpg

both video0, video1, video2 are recording perfectly I can view it with mplayer

dmesg |grep ivtv:                                                                                  
ivtv: Start initialization, version 1.4.1                                                                           
ivtv0: Initializing card 0
ivtv0: Autodetected Hauppauge card (cx23416 based)
ivtv 0000:08:08.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
ivtv0: Autodetected WinTV PVR 500 (unit #1)
cx25840 1-0044: cx25843-24 found @ 0x88 (ivtv i2c driver #0)
tuner 1-0060: chip found @ 0xc0 (ivtv i2c driver #0)
tuner 1-0061: chip found @ 0xc2 (ivtv i2c driver #0)
wm8775 1-001b: chip found @ 0x36 (ivtv i2c driver #0)
IRQ 18/ivtv0: IRQF_DISABLED is not guaranteed on shared IRQs
ivtv0: Registered device video0 for encoder MPG (4096 kB)
ivtv0: Registered device video32 for encoder YUV (2048 kB)
ivtv0: Registered device vbi0 for encoder VBI (1024 kB)
ivtv0: Registered device video24 for encoder PCM (320 kB)
ivtv0: Registered device radio0 for encoder radio
ivtv0: Initialized card: WinTV PVR 500 (unit #1)
ivtv1: Initializing card 1
ivtv1: Autodetected Hauppauge card (cx23416 based)
ivtv 0000:08:09.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
ivtv1: Correcting tveeprom data: no radio present on second unit
ivtv1: Autodetected WinTV PVR 500 (unit #2)
cx25840 4-0044: cx25843-24 found @ 0x88 (ivtv i2c driver #1)
tuner 4-0061: chip found @ 0xc2 (ivtv i2c driver #1)
wm8775 4-001b: chip found @ 0x36 (ivtv i2c driver #1)
IRQ 19/ivtv1: IRQF_DISABLED is not guaranteed on shared IRQs
ivtv1: Registered device video1 for encoder MPG (4096 kB)
ivtv1: Registered device video33 for encoder YUV (2048 kB)
ivtv1: Registered device vbi1 for encoder VBI (1024 kB)
ivtv1: Registered device video25 for encoder PCM (320 kB)
ivtv1: Initialized card: WinTV PVR 500 (unit #2)
ivtv: End initialization
ivtv 0000:08:09.0: firmware: requesting v4l-cx2341x-enc.fw
ivtv 0000:08:08.0: firmware: requesting v4l-cx2341x-enc.fw
ivtv1: Loaded v4l-cx2341x-enc.fw firmware (376836 bytes)
ivtv0: Loaded v4l-cx2341x-enc.fw firmware (376836 bytes)
ivtv1: Encoder revision: 0x02060039
ivtv0: Encoder revision: 0x02060039


dmesg |grep cx18:
cx18:  Start initialization, version 1.2.0
cx18-0: Initializing card 0
cx18-0: Autodetected Hauppauge card
cx18 0000:07:01.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
cx18-0: cx23418 revision 01010000 (B)
cx18-0: Autodetected Hauppauge HVR-1600
cx18-0: Simultaneous Digital and Analog TV capture supported
IRQ 16/cx18-0: IRQF_DISABLED is not guaranteed on shared IRQs
tuner 3-0061: chip found @ 0xc2 (cx18 i2c driver #0-1)
cs5345 2-004c: chip found @ 0x98 (cx18 i2c driver #0-0)
cx18-0: Registered device video2 for encoder MPEG (64 x 32 kB)
DVB: registering new adapter (cx18)
cx18-0: DVB Frontend registered
cx18-0: Registered DVB adapter0 for TS (32 x 32 kB)
cx18-0: Registered device video34 for encoder YUV (16 x 128 kB)
cx18-0: Registered device vbi2 for encoder VBI (20 x 51984 bytes)
cx18-0: Registered device video26 for encoder PCM audio (256 x 4 kB)
cx18-0: Initialized card: Hauppauge HVR-1600
cx18:  End initialization
cx18 0000:07:01.0: firmware: requesting v4l-cx23418-cpu.fw
cx18-0: loaded v4l-cx23418-cpu.fw firmware (158332 bytes)
cx18 0000:07:01.0: firmware: requesting v4l-cx23418-apu.fw
cx18-0: loaded v4l-cx23418-apu.fw firmware V00120000 (141200 bytes)
cx18-0: FW version: 0.0.74.0 (Release 2007/03/12)
cx18 0000:07:01.0: firmware: requesting v4l-cx23418-cpu.fw
cx18 0000:07:01.0: firmware: requesting v4l-cx23418-apu.fw
cx18 0000:07:01.0: firmware: requesting v4l-cx23418-dig.fw
cx18-0 843: loaded v4l-cx23418-dig.fw firmware (16382 bytes)
cx18-0 843: verified load of v4l-cx23418-dig.fw firmware (16382 bytes)

at first there was error in dmesg about the HVR-1600 and firmware so I've 
downloaded and copied  v4l-cx23418-apu.fw, v4l-cx23418-cpu.fw and
v4l-cx23418-dig.fw to /lib/firmware and the error message in dmesg went away.

but since then I can't configure my card in mythtv-setup. I only get fail to 
open or something similar (it's in french)

what more do I need to check

Thanks,
-- 
Claude Gélinas agr.
Phyto Ressources inc.


More information about the mythtv-users mailing list