[mythtv-users] 720p HD content from WPVI in Philly periodic a/v sync issues

Byron Poland wpoland at gmail.com
Fri Dec 11 20:49:00 UTC 2009


On Fri, Dec 11, 2009 at 1:03 PM, Taylor Ralph <tralph11 at yahoo.com> wrote:

> --- On Fri, 12/11/09, Andrew Gallatin <gallatin at cs.duke.edu> wrote:
>
> > From: Andrew Gallatin <gallatin at cs.duke.edu>
> > Subject: Re: [mythtv-users] 720p HD content from WPVI in Philly periodic
> a/v sync issues
> > To: "Discussion about mythtv" <mythtv-users at mythtv.org>
> > Date: Friday, December 11, 2009, 10:54 AM
> > Byron Poland [wpoland at gmail.com]
> > wrote:
> > > for the past couple of months anything I record from
> > WPVI in Philadelphia
> > > (delivered via clear qam from Verizon FIOS in
> > Wilmington, DE), has had
> > > playback problems where the video and audio fall out
> > of sync, and myth then
> > > speeds up the video and/or drops frames for a second
> > or 2 to catch up.  I've
> > > read the list and seen other threads describing a
> > similar phenomenon,
> > > including being isolated to one channel.  All
> > other 720p and 1080 recordings
> >
> > <..>
> >
> > I think this is the same problem as reported here, nearly
> > 2 years ago:
> >   http://www.gossamer-threads.com/lists/mythtv/dev/317736
> >
> > As DanielK said "they are just using an encoding extension
> > we don't
> > support very well.....I believe they are broadcasting about
> > 40 fps on
> > a 60fps stream and marking some of the frames as
> > repeatable"
> > If this is true, you may have luck complaining to the
> > broadcaster like
> > the people in that thread did.  Unfortunately, that's
> > not much of an
> > option for me, as multiple broadcasters in my market have
> > their
> > encoders setup this way.  The only way I was able to
> > play back these
> > sorts of streams was by using a non-MythTV front end (sigma
> > based
> > SageTV HD100).
> >
> > I'd love to come back to MythTV, and I'm eagerly looking
> > forward to a
> > fix to this.  I have a mythbox setup running trunk,
> > and I'm happy to
> > test patches, make snippets of these streams available to
> > the devs,
> > etc.
> >
> > Drew
>
> I've got a couple patches attached that might help. They are both based on
> 0.22-fixes but the latest av-sync changes to trunk will probably break the
> repeat_pict patch. Let us know if these help at all.
>
> Also, if you provide samples then I'll have a look.
>
> --
> Taylor
>
>
I don't know if I will get a chance to build with the patches for a few
days.  I'll try and get a snippet of a sample file out at in the next day or
so though  Thanks!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20091211/bfca72d2/attachment.htm>


More information about the mythtv-users mailing list