[mythtv-users] 720p HD content from WPVI in Philly periodic a/v sync issues

Byron Poland wpoland at gmail.com
Sun Dec 13 19:17:19 UTC 2009


On Sun, Dec 13, 2009 at 1:57 PM, Taylor Ralph <tralph11 at yahoo.com> wrote:
>>
>> One significant difference between your setup and my setup
>> is that you are using the DRM vsync method. Could you try
>> setting the return equal to false at the end of
>> DRMVideoSync::TryInit in libs/libmythtv/vsync.cpp. This
>> should cause you to use one of the other vsync methods.
>> Please report your results and include logs with -v
>> playback,timestamp.
>>
>
> Byron,
>
> BTW, wanted to make sure you also apply the latest patch when testing with DRM disabled. I've confirmed that the latest patch calculates the correct delays between frames when repeats occur. So I'm guessing that DRM may not be waiting the appropriate amount of time or something. This is why I need the timestamp information in your logs.
>
> Thanks,
>
> --
> Taylor


Taylor,

these are all cases with the patch.

With the DRM timing, the sample playback is crap.
With openGL timing enabled via playback setup, it looks a little
better, but still a lot of issues.
With Usleep and wait timing (the result of changing the code you
suggested), playback looks great!

here are 3 log files for the case above. (on my dropbox as pastebin
was throwing an error)
http://dl.dropbox.com/u/2386241/wpvi-with-patch-DRM.log.gz
http://dl.dropbox.com/u/2386241/wpvi-with-patch-opengl.log.gz
http://dl.dropbox.com/u/2386241/wpvi-with-patch-Usleep.log.gz

Is there any way to disable the DRM timing method (or enable the
Usleep one) without modifying the code?

Are you going to submit this patch for possible inclusion upstream?
it makes unwatchable recordings watchable for me.  I appreciate your
effort, and time.

Thanks
-Byron


More information about the mythtv-users mailing list