[mythtv-users] Question about testing a patch

Harry Devine lifter89 at comcast.net
Tue Dec 15 02:40:13 UTC 2009


Chris Ribe wrote:
>
>     Thanks!  I checked out the revision.  Before I change anything I
>     want to try a base compile to work out any bugs.  I ran
>     mythbackend --version to get the compiled in options. Here's my
>     output:
>
>     hdevine at hdevine-desktop:~/mythtv-0-22/mythtv$ mythbackend --version
>     Please include all output in bug reports.
>     MythTV Version   : 22957
>     MythTV Branch    : branches/release-0-22-fixes
>     Network Protocol : 50
>     Library API      : 0.22.20091023-1
>     QT Version       : 4.5.2
>     Options compiled in:
>     linux profile using_oss using_alsa using_pulse using_jack
>     using_backend using_dvb using_firewire using_frontend
>     using_glx_proc_addr_arb using_hdhomerun using_hdpvr using_iptv
>     using_ivtv using_joystick_menu using_libfftw3 using_lirc
>     using_mheg using_opengl_video using_opengl_vsync using_qtwebkit
>     using_v4l using_x11 using_xrandr using_xv using_xvmc
>     using_xvmc_vld using_xvmcw using_bindings_perl
>     using_bindings_python using_opengl using_vdpau
>     using_ffmpeg_threads using_libavc_5_3 using_live using_mheg
>
>
>     Can I assume that I need --enable-??? for each option?  Or are
>     some of them on by default?  I couldn't really tell from the
>     ./configure help screen.
>
>
>  
> Almost all of them will be enabled by default if you have the 
> necessary library headers installed.  You will probably need to 
> install the -dev versions of a number of libraries before this is the 
> case.  This can generally be accomplished by using aptitude to find 
> and install the appropriate packages.  For example, to enable 
> libfftw3, you will need to install libfftw3-dev.  You can get an idea 
> of what you need to install by running ./configure and seeing what 
> gets enabled.
>
> -chris
> ------------------------------------------------------------------------
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>   

Thanks.  I just tried and got the error "qmake for Qt4 not found.  
Please specify the correct qmake with --qmake=".  I'm trying to get to 
the Wiki now to see if it has any info but it must be down.  It keeps 
timing out on me.  Is there any documentation (other than "check the 
dev-list") that loosely lists what should be installed to compile from 
source?  I see lots of people saying "I compile all the time", but I've 
yet to see a decisive "here's what you need".

Thanks,
Harry



More information about the mythtv-users mailing list