[mythtv-users] how to correct these error messages?

Eppo Eppleston eppo120 at gmail.com
Fri Dec 18 13:25:12 UTC 2009


ok, so i was using trunk and switch to the stable 0.22 release. when i made
the change, i upgraded to the current firmware for the HDPVR, grabbed the
current driver, and upgraded my server to kernel 2.6.28-17-server running
ubuntu 9.04.
the problem i'm having is that some recordings wont play, and i'm getting
errors like this on my backend:
2009-12-17 20:00:04.493 Started recording: Bones "The Doctor in the Den":
channel 1505 on cardid 1, sourceid 1
2009-12-17 20:00:05.497 Reschedule requested for id 0.
2009-12-17 20:00:05.612 AFD: Opened codec 0x1454d40, id(H264) type(Video)
2009-12-17 20:00:05.632 AFD: codec AC3 has 2 channels
2009-12-17 20:00:05.633 AFD: Opened codec 0x1453e10, id(AC3) type(Audio)
2009-12-17 20:00:05.692 [h264 @ 0x7fc53c6f7940]B picture before any
references, skipping
2009-12-17 20:00:05.693 [h264 @ 0x7fc53c6f7940]decode_slice_header error
2009-12-17 20:00:05.694 [h264 @ 0x7fc53c6f7940]no frame!
2009-12-17 20:00:05.694 AFD Error: Unknown decoding error
2009-12-17 20:00:05.695 [h264 @ 0x7fc53c6f7940]B picture before any
references, skipping
2009-12-17 20:00:05.695 [h264 @ 0x7fc53c6f7940]decode_slice_header error
2009-12-17 20:00:05.696 [h264 @ 0x7fc53c6f7940]no frame!
2009-12-17 20:00:05.697 AFD Error: Unknown decoding error
2009-12-17 20:00:05.698 [h264 @ 0x7fc53c6f7940]B picture before any
references, skipping
2009-12-17 20:00:05.698 [h264 @ 0x7fc53c6f7940]decode_slice_header error
2009-12-17 20:00:05.699 [h264 @ 0x7fc53c6f7940]no frame!
2009-12-17 20:00:05.699 AFD Error: Unknown decoding error
2009-12-17 20:00:05.707 Preview: Grabbed preview
'/home/ataraid/Mythtv/1011_20091217193000.mpg' 720x480 at 64s
2009-12-17 20:00:05.938 Scheduled 142 items in 0.4 = 0.00 match + 0.44 place
2009-12-17 20:00:10.096 AutoExpire: CalcParams(): Max required Free Space:
3.0 GB w/freq: 15 min
2009-12-17 20:00:12.043 DevRdB(/dev/video0) Error: Poll giving up
2009-12-17 20:00:12.053 MPEGRec(/dev/video0) Error: Device error detected
2009-12-17 20:00:12.069 DevRdB(/dev/video0): Stop(): Not running.

then a bunch of these that go on
2009-12-17 20:00:35.781 AFD: Opened codec 0x17b2930, id(H264) type(Video)
2009-12-17 20:00:35.790 AFD: codec AC3 has 2 channels
2009-12-17 20:00:35.791 AFD: Opened codec 0x17be680, id(AC3) type(Audio)
2009-12-17 20:00:36.310 [h264 @ 0x7f60b7cfd940]B picture before any
references, skipping
2009-12-17 20:00:36.311 [h264 @ 0x7f60b7cfd940]decode_slice_header error
2009-12-17 20:00:36.311 [h264 @ 0x7f60b7cfd940]no frame!
2009-12-17 20:00:36.312 AFD Error: Unknown decoding error
2009-12-17 20:00:36.313 [h264 @ 0x7f60b7cfd940]B picture before any
references, skipping
2009-12-17 20:00:36.313 [h264 @ 0x7f60b7cfd940]decode_slice_header error
2009-12-17 20:00:36.314 [h264 @ 0x7f60b7cfd940]no frame!
2009-12-17 20:00:36.315 AFD Error: Unknown decoding error
2009-12-17 20:00:36.315 [h264 @ 0x7f60b7cfd940]B picture before any
references, skipping
2009-12-17 20:00:36.316 [h264 @ 0x7f60b7cfd940]decode_slice_header error
2009-12-17 20:00:36.316 [h264 @ 0x7f60b7cfd940]no frame!
2009-12-17 20:00:36.317 AFD Error: Unknown decoding error
2009-12-17 20:00:36.776 [h264 @ 0x7f60b7cfd940]B picture before any
references, skipping
2009-12-17 20:00:36.777 [h264 @ 0x7f60b7cfd940]decode_slice_header error
2009-12-17 20:00:36.778 [h264 @ 0x7f60b7cfd940]no frame!
2009-12-17 20:00:36.778 AFD Error: Unknown decoding error
2009-12-17 20:00:36.779 [h264 @ 0x7f60b7cfd940]B picture before any
references, skipping
2009-12-17 20:00:36.779 [h264 @ 0x7f60b7cfd940]decode_slice_header error
2009-12-17 20:00:36.780 [h264 @ 0x7f60b7cfd940]no frame!
2009-12-17 20:00:36.781 AFD Error: Unknown decoding error
2009-12-17 20:00:36.781 [h264 @ 0x7f60b7cfd940]B picture before any
references, skipping
2009-12-17 20:00:36.782 [h264 @ 0x7f60b7cfd940]decode_slice_header error
2009-12-17 20:00:36.783 [h264 @ 0x7f60b7cfd940]no frame!
2009-12-17 20:00:36.783 AFD Error: Unknown decoding error
2009-12-17 20:00:37.142 [h264 @ 0x7f60b7cfd940]B picture before any
references, skipping
2009-12-17 20:00:37.144 [h264 @ 0x7f60b7cfd940]decode_slice_header error
2009-12-17 20:00:37.144 [h264 @ 0x7f60b7cfd940]no frame!
2009-12-17 20:00:37.145 AFD Error: Unknown decoding error


until this:
2009-12-17 21:00:05.638 AFD Error: Unknown decoding error
2009-12-17 21:00:05.639 [h264 @ 0x7fbcee210940]B picture before any
references, skipping
2009-12-17 21:00:05.640 [h264 @ 0x7fbcee210940]decode_slice_header error
2009-12-17 21:00:05.640 [h264 @ 0x7fbcee210940]no frame!
2009-12-17 21:00:05.641 AFD Error: Unknown decoding error
Segmentation fault
2009-12-17 21:00:05.983 Preview Error: Encountered problems running
'/usr/local/bin/mythbackend --generate-preview 0x0 --chanid 1505 --starttime
20091217200000 '

then this which also seems to be related:

2009-12-17 21:00:40.492
RingBuf(/home/ataraid/Mythtv/1505_20091217200000.mpg): Waited 2.0 seconds
for data to become availab$
2009-12-17 21:00:40.836 AFD: Opened codec 0x2630c60, id(H264) type(Video)
2009-12-17 21:00:40.837 AFD: codec AC3 has 6 channels
2009-12-17 21:00:40.838 AFD: Opened codec 0x2632bc0, id(AC3) type(Audio)
2009-12-17 21:00:40.925 AFD Error: Unknown decoding error
2009-12-17 21:00:41.030 AFD Error: Unknown decoding error
2009-12-17 21:00:41.031 AFD Error: Unknown decoding error
2009-12-17 21:00:41.115 AFD Error: Unknown decoding error
*** glibc detected *** /usr/local/bin/mythcommflag: free(): invalid next
size (normal): 0x0000000002aadaf0 ***
======= Backtrace: =========
/lib/libc.so.6[0x7f7bce323cb8]
/lib/libc.so.6(cfree+0x76)[0x7f7bce326276]
/usr/local/lib/libmythtv-0.22.so.0(_ZN12VideoBuffers13DeleteBuffersEv+0x113)[0x7f7bd4ce4613]
/usr/local/lib/libmythtv-0.22.so.0(_ZN15VideoOutputNull12InputChangedERK5QSizef11MythCodecIDPv+0x6a5)[0x7f7bd4ce34c5]
/usr/local/lib/libmythtv-0.22.so.0(_ZN17NuppelVideoPlayer11ReinitVideoEv+0x460)[0x7f7bd4c154a0]
/usr/local/lib/libmythtv-0.22.so.0(_ZN17NuppelVideoPlayer14SetVideoParamsEiidif13FrameScanTypeb+0xfd)[0x7f7bd4c15a5d]
/usr/local/lib/libmythtv-0.22.so.0(_ZN15AvFormatDecoder17H264PreProcessPktEP8AVStreamP8AVPacket+0x19b)[0x7f7bd4c6371b]
/usr/local/lib/libmythtv-0.22.so.0(_ZN15AvFormatDecoder8GetFrameEi+0x6b2d)[0x7f7bd4c76bad]
/usr/local/lib/libmythtv-0.22.so.0(_ZN15AvFormatDecoder9SeekResetExjbb+0x693)[0x7f7bd4c5b4e3]
/usr/local/lib/libmythtv-0.22.so.0(_ZN11DecoderBase13DoFastForwardExb+0x1f2)[0x7f7bd4c4a472]
/usr/local/lib/libmythtv-0.22.so.0(_ZN15AvFormatDecoder13DoFastForwardExb+0xba)[0x7f7bd4c5c5aa]
/usr/local/lib/libmythtv-0.22.so.0(_ZN17NuppelVideoPlayer13DoFastForwardEv+0x9a)[0x7f7bd4c10b7a]
/usr/local/lib/libmythtv-0.22.so.0(_ZN17NuppelVideoPlayer13DoJumpToFrameEx+0x97)[0x7f7bd4c11207]
/usr/local/lib/libmythtv-0.22.so.0(_ZN17NuppelVideoPlayer16GetRawVideoFrameEx+0x66)[0x7f7bd4c1c606]
/usr/local/bin/mythcommflag[0x40a0d2]
/usr/local/bin/mythcommflag[0x426d99]
/usr/local/bin/mythcommflag[0x46d4e7]
/usr/local/bin/mythcommflag[0x46def0]
/usr/local/bin/mythcommflag[0x46f8af]
/usr/local/bin/mythcommflag[0x4766ad]
/lib/libc.so.6(__libc_start_main+0xe6)[0x7f7bce2ca5a6]
/usr/local/bin/mythcommflag[0x407ef9]

<removed Memory Map info>


then this a little bit further down in the logs:
2009-12-17 21:00:44.549 AFD: Opened codec 0x12ef5d0, id(H264) type(Video)
2009-12-17 21:00:44.550 AFD: codec AC3 has 6 channels
2009-12-17 21:00:44.551 AFD: Opened codec 0x12efa00, id(AC3) type(Audio)
2009-12-17 21:00:44.631 [h264 @ 0x7f34dfbec940]B picture before any
references, skipping
2009-12-17 21:00:44.631 [h264 @ 0x7f34dfbec940]decode_slice_header error
2009-12-17 21:00:44.632 [h264 @ 0x7f34dfbec940]no frame!
2009-12-17 21:00:44.633 AFD Error: Unknown decoding error
2009-12-17 21:00:44.633 [h264 @ 0x7f34dfbec940]B picture before any
references, skipping
2009-12-17 21:00:44.634 [h264 @ 0x7f34dfbec940]decode_slice_header error
2009-12-17 21:00:44.634 [h264 @ 0x7f34dfbec940]no frame!
2009-12-17 21:00:44.635 AFD Error: Unknown decoding error
2009-12-17 21:00:44.636 [h264 @ 0x7f34dfbec940]B picture before any
references, skipping
2009-12-17 21:00:44.636 [h264 @ 0x7f34dfbec940]decode_slice_header error
2009-12-17 21:00:44.637 [h264 @ 0x7f34dfbec940]no frame!
2009-12-17 21:00:44.637 AFD Error: Unknown decoding error
Segmentation fault


Could anyone help me resolve these errors?
thanks
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20091218/ffd79285/attachment.htm>


More information about the mythtv-users mailing list