[mythtv-users] Database backup (was Re: connect an 0.22 front end to an 0.21 backend)

Michael T. Dean mtdean at thirdcontact.com
Mon Dec 21 15:15:18 UTC 2009


On 12/21/2009 03:37 AM, Mike McMullin wrote:
> On Sun, 2009-12-20 at 23:01 -0500, Michael T. Dean wrote:
>   
>> On 12/20/2009 10:50 PM, Mike McMullin wrote:
>>     
>>>   Thanks Mike, I'll see if I can get the earlier version put on the
>>> laptop, frankly I'd love to just dump oS, but until I can get the
>>> database backup script to run, I'm kinda stuck with it.
>>>       
>> The database backup script is something I /can/ help you with (and feel 
>> free to step back into IRC if that was you in there earlier--I'm sphery 
>> in there).
>>
>> What, specifically is the problem with it?
>>     
>   Not it, it's openSuSE that is the culprit, a number of the perl
> requirements fail even though they are installed.
>   
>> If it's a lack of Perl support on your system (I don't know what oS11.1 
>> is), you can always run the backup script from any other system with 
>> Perl and the MySQL client tools installed (i.e. an Ubuntu LiveCD or your 
>> frontend system).  You don't need to run it on the same host running the 
>> database server.
>>
>> See, also, http://www.mythtv.org/wiki/Database_Backup_and_Restore .  The 
>> first section ( 
>> http://www.mythtv.org/wiki/Database_Backup_and_Restore#Script-based_Database_Backup_and_Restore 
>> ) includes directions for downloading an up-to-date copy of the backup 
>> script.
>>
>> If there is a problem, I'd love to fix it, so I'd appreciate your feedback.
>>     
>   I'll try the 9.04 live cd and see how this works.  Thanks for the
> heads up.

Note, also, that you can even do a backup of a 0.21-fixes database from 
your 0.22-fixes frontend install.  Forgot to mention that.  The 
backup/restore scripts currently (still) have no MythTV version 
dependencies (and I'm trying to keep them that way).

Mike


More information about the mythtv-users mailing list