[mythtv-users] Match display refresh rate to video framerate

Johnny Walker johnnyjboss at gmail.com
Tue Dec 29 15:47:45 UTC 2009


On Tue, Dec 29, 2009 at 3:51 AM, Jean-Yves Avenard <jyavenard at gmail.com> wrote:
> Hi
>
> 2009/12/28 Schuren, Mark <schurenmark at versanet.de>:
>
>> It shows 3 playbacks, first with 25fps, second with 24
>> fps, and the third with a 60i video. Myth still detects
>> (or calculates) exactly '49.832 Hz' for the 50Hz mode,
>> and then picks the wrong one ('59.798 Hz') for 25fps video.
>> I'm pretty sure that is the cause of the problem.
>
> If you were using my xorg.conf you would have about a dozen of refresh
> rates showing up.
>
> http://www.avenard.org/media/Patches_%26_Add-Ons/Entries/2008/9/5_xorg.conf_and_specific_refresh_rates.html
>
> No idea what you are doing ; your xorg.conf looks allright to me.
>
>>
>> Here is my xorg.conf:
>> http://mythtv-users.pastebin.ca/1729357
>> My TV does not support 25Hz or 30Hz modes, just 24, 50
>> and 60. But even when ignoring the EDID values, I get
>> the exact same results :(
>
> Anyhow ; try trunk ; or recompile 0.22-fixes with
> http://svn.mythtv.org/trac/changeset/23023 (it will apply nicely on
> 0.22-fixes).
>
> It should fix your issue ; I take a much broader approach now ; 50Hz
> will be selected for any rate > 49Hz and < 51Hz

Hey not to hijack your thread but I just purchased a Panasonic
TC-P50C1 50" Plasma. It has native resolution of the following:

1,049,088 (1,366 (W)  768 (H)) - [4,098  768 dots]

The manual is located at http://service.us.panasonic.com/OPERMANPDF/TCP42C1.pdf

I'm curious how I am supposed to determine and create the correct
modelines for xorg.conf. I'm using mythbuntu and there aren't any
modelines present in the current xorg.conf. It is currently only using
1280 x 720 and it seems to move around on me. Sometimes the menus
aren't quite on the screen and after I adjusted that using the screen
size tool (moving the arrows) I then got a dotted green line across
the bottom of the screen for half the duration of the movie I was
watching last night. It suddenly shifted at one point and the image
moved downward revealing the xfce panel at the top of the screen.

I figured getting the modelines created was a good next step.

I'm on the nVidia 185.18.36 using the Acer Revo as a frontend on HDMI.


More information about the mythtv-users mailing list