[mythtv-users] Lirc Issue, Fedora 10, PRV250, Intermitant Delay with remote sends in MythTV

David Krainess davidkrainess at yahoo.com
Sun Jan 18 13:53:08 UTC 2009




--- On Sat, 1/17/09, Michael T. Dean <mtdean at thirdcontact.com> wrote:

> From: Michael T. Dean <mtdean at thirdcontact.com>
> Subject: Re: [mythtv-users] Lirc Issue, Fedora 10, PRV250, Intermitant Delay with remote sends in MythTV
> To: "Discussion about mythtv" <mythtv-users at mythtv.org>
> Date: Saturday, January 17, 2009, 10:16 PM
> On 01/17/2009 11:23 PM, Bruce Taber wrote:
> > Michael T. Dean wrote:
> >   
> >>>  here you go:
> >>> <<BEGIN OUTPUT>>
> >>> Please include all output in bug reports.
> >>> MythTV Version   : 19631M
> >>> MythTV Branch    : branches/release-0-21-fixes
> >>> Library API      : 0.21.20080304-1
> >>> Network Protocol : 40
> >>> Options compiled in:
> >>>  linux release using_oss using_alsa using_arts
> using_jack
> >>> using_backend using_dbox2 using_dvb
> using_firewire using_frontend
> >>> using_hdhomerun using_iptv using_ivtv
> using_joystick_menu
> >>> using_libfftw3 using_lirc using_opengl_vsync
> using_opengl_video
> >>> using_v4l using_x11 using_xrandr using_xv
> using_xvmc using_xvmcw
> >>> using_xvmc_vld using_bindings_perl
> using_bindings_python using_opengl
> >>> using_ffmpeg_threads using_libavc_5_3
> using_live
> >>> <<END OUTPUT>>
> >>>       
> >>
> http://www.gossamer-threads.com/lists/mythtv/users/366075#366075
> and the
> >> rest of the thread.
> > Yes, I'm still seeing this same behavior on
> occasion. Although, the
> > incidence of it happening is greatly diminished now.
> Before, it could be
> > seen and duplicated within a couple of minutes of
> starting any
> > recording. Now, it seems to be more sporadic.
> > 
> > The system is a separate frontend. Both the backend
> and frontend are on
> > Fedora 10 using the same mythbackend version as above.
> The frontend
> > system is running Gnome desktop rather than XFCE. I
> have completely
> > uninstalled the X and gnome screensavers. The CPU
> usage stays around
> > 15-20%. The keyboard can clear the problem within a
> second or two and
> > commercial skip will also clear the logjam. I have
> checked and noticed
> > IRW responds immediately to the remote button presses.
> 
> By quoting the tail end of that thread, I meant you should
> try running /with/ and /without/ gnome-screensaver active
> (restarting the frontend after activating/deactivating the
> screensaver).  If there's a change in the behavior
> without the screensaver active, please let me know.  If
> it's the same with or without the screensaver, then
> it's some issue completely unrelated to the screensaver.
> 
> Mike

I have the problem with or without a screen saver installed (and or running), thanks for the thread link (I was searching for "lirc delay", and didn't get a hit in the archive, or I would have seen that thread (if I just searched "remote delay" instead :( ).  

Anyways, I suspect there is some relation to that thread with the issue I am having.  I will hypothesize that there is a combination of things in GNOME (or Fedora 10) that could be causing this.  I'm a going to try a serial receiver, and then, perhaps KDE and to try to root this out.  Intermittant errors are really annoying.

Is anybody else seeing this?  Please note:
1. Recent system update <= 1 month  (yes/no)
2. Linux distro
3. X display (Gnome, KDE..etc) in use
4. Remote input (PVRxxx, serial..etc)
5. MythTV build (mythfrontend --version)




      


More information about the mythtv-users mailing list