[mythtv-users] question/set top box

Srinivas Gowrisanker sgowrisanker at gmail.com
Sun Jul 26 16:33:22 UTC 2009


immy at linuxhome ~]$ irsend LIST blaster ""
irsend: 0000000000000290 mute
irsend: 0000000000000490 vol+
irsend: 0000000000000c90 vol-
irsend: 0000000000000006 power
irsend: 0000000000000806 menu
irsend: 0000000000000c0b guide
irsend: 0000000000000c05 info
irsend: 0000000000000c09 up
irsend: 0000000000000c01 down
irsend: 0000000000000c0e left
irsend: 0000000000000c06 right
irsend: 0000000000000807 ok
irsend: 000000000000080b exit
irsend: 0000000000000205 options
irsend: 0000000000000209 widgets
irsend: 000000000000080a ondemand
irsend: 0000000000000805 favorites
irsend: 0000000000000803 last
irsend: 0000000000000c0f fiostv
irsend: 000000000000000a ch+
irsend: 0000000000000002 ch-
irsend: 0000000000000c08 previous
irsend: 0000000000000c00 dvr
irsend: 0000000000000c07 next
irsend: 0000000000000808 rewind
irsend: 0000000000000800 play-pause
irsend: 0000000000000804 fastforward
irsend: 000000000000080c stop
irsend: 0000000000000c03 record
irsend: 000000000000000f 1
irsend: 0000000000000007 2
irsend: 000000000000000b 3
irsend: 0000000000000003 4
irsend: 000000000000000d 5
irsend: 0000000000000005 6
irsend: 0000000000000009 7
irsend: 0000000000000001 8
irsend: 000000000000000e 9
irsend: 0000000000000000 0
irsend: 0000000000000201 *
irsend: 0000000000000203 #
irsend: 0000000000000801 yellow
irsend: 000000000000040e blue
irsend: 0000000000000406 red
irsend: 000000000000040a green
irsend: 000000000000080d av
irsend: 0000000000000403 pip
irsend: 000000000000040d pip-change

[jimmy at linuxhome ~]$ irsend SEND_ONCE blaster 2
gives nothing. Its supposed to change the stb channel to 2?

I do have the stuff for happauge remote and the stb remote in one 
lircd.conf file. See attached file. I have also attached the channel 
change script. I have
alias char-major-61 lirc_i2c in /etc/modprobe.conf

I have the IR blaster connected to the pvr card (in direct line-of-sight 
to stb). I have to get the happauge remote working first?

[jimmy at linuxhome ~]$ sudo modprobe lirc_zilog
[sudo] password for jimmy:
WARNING: Deprecated config file /etc/modprobe.conf, all config files 
belong into /etc/modprobe.d/.
WARNING: All config files need .conf: /etc/modprobe.d/lirc, it will be 
ignored in a future release.

The modules are not loading properly I guess or I dont have the proper 
files at the proper place. What is the right way to do it?

Thanks
Jimmy


On 07/26/2009 12:07 AM, Jarod Wilson wrote:
> On 07/25/2009 09:56 PM, Srinivas Gowrisanker wrote:
>> This is driving me nuts (getting the remote control) now!! Here is what
>> I have done so far
>> I pretty much followed this
>> (http://solargap.wordpress.com/2007/06/03/mythdora-40-and-hauppauge-pvr-150-with-ir-blaster-support/) 
>>
>>
>>
>> 1. placed happauge PVR-150 firmware in /lib/firmware
>> 2. used the script changing channel.pl (when I dont use this the script
>> I could just use the Motorola QIP-2500-3 remote set to ch 3, start
>> mythtfrontend and use the remote to watch tv controlling the stb, now
>> mythttv will not respond to the remote). But when I use the script the I
>> loose tuning and can't watch anything, but mythtv frontednd responds to
>> the remote!
>> so when I do
>> sudo /usr/local/bin/change_chan.pl 2
>> channel changing 2
>> irsend: command failed: SEND_ONCE blaster 2
>> irsend: unknown command: "2"
>> There is something wrong with the script!!
>> 3. I used the QIP6200-2 for my lircd.conf from
>> (http://lirc.sourceforge.net/remotes/motorola/QIP6200-2) for my stb
>> remote. THis has the same number inside the battery compartment as mine!
>> also used part of lircd.conf (from the very first link in this email)
>> for my greay happauge. THe happauge still does not work!!
>
> I don't entirely follow... But I would do is take the QIP6200-2 config 
> file and the hauppauge config file 
> (http://lirc.sourceforge.net/remotes/hauppauge/lircd.conf.hauppauge) 
> and merge them into one file. Then restart lircd. Then run irw and 
> push some buttons on the remote, see if irw starts reporting button 
> presses. Next, try 'irsend LIST Motorola_QIP6200-2 ""', and verify 
> that irsend sees all the appropriate codes. The try a manual 'irsend 
> SEND_ONCE Motorola_QIP6200-2 2' and see if that work. Then go from 
> there...
>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: lircd-conf.txt
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20090726/ef88e585/attachment.txt>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: change_chan-pl.txt
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20090726/ef88e585/attachment-0001.txt>


More information about the mythtv-users mailing list