[mythtv-users] [Bulk] Re: Problem with logitech remote on menus

Christian Szpilfogel chrisznews4 at rogers.com
Sun Jun 7 01:56:50 UTC 2009


Steve V wrote:
> Great idea, just tried irw. The logitech send the correct command only 
> thing is it sends it twice. That shouldn't matter as 2 ups would just 
> move me up 2 menu items. Also interestingly it actually doesn't move 2 
> menu items, basically either Myth or Soundgraph receiver is ignoring 
> the second identical command. When I use the direction buttons I only 
> get one movement per push.
> The problem is only in the Myth submenus.
>
> I tried a different test. I used the Logitech remote to get to the submenu then I picked up the imon remote and pushed up and down a few times. This did the expected scroll up and down through the submenu. While the submenu was still on the screen I picked up the logitech and pushed up and down and it worked perfectly.
>
> I can recreate this situation at will, everytime if I only use the Logitech, it jumps out of the submenu, while the imon does not, then if I use the logitech after the imon the logitech works fine for that instance.
>
> Got me baffled, it doesn't seem to be a problem with the logitech setup. 
>   
Given irw is doing as you expect with the exception of the double 
commands, then it may be in your lircrc. In lircrc, the repeat tag will 
absorb the duplicate key press and that is probably why your menus are 
only advancing once for double commands. You may wish to verify that 
your lircrc is correct for your set up. There are many many variations 
out there so it is hard to say what is in yours. But do check that it is 
mapped as you would expect with ir command to myth command.



More information about the mythtv-users mailing list