[mythtv-users] unable to do a smart upgrade due to lirc

Gabe Rubin gaberubin at gmail.com
Sun Jun 21 04:28:58 UTC 2009


On Sat, Jun 20, 2009 at 3:05 PM, Harry Orenstein<holists at verizon.net> wrote:
> On Saturday 20 June 2009 03:48:25 pm Gabe Rubin wrote:
>> Hi all,
>>
>> When I try to do a smart upgrade (FC10 using atrpms and standard
>> repos), I get the following error:
>>
>> error: file /usr/lib/liblirc_client.so.0.2.1 from install of
>> lirc-libs-0.8.5-2.fc10.i386 conflicts with file from package
>> liblirc_client0-0.8.4a-81.fc10.i386
>>
>> Any ideas what to do short of removing lirc?
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>
> I did it by upgrading while excluding all lirc packages.  Then I force removed
> the liblirc_client0 package (rpm -e --nodeps) and upgraded lirc.  It should be
> possible to do the remove first and then upgrade without any excludes.
>
> When you have upgraded, remember that the format of the config files for the
> daemon have changed (/etc/init.d and /etc/sysconfig).  I use lirc_i2c, so I am
> using unmodified config files but I had to add lirc.modules to
> /etc/sysconfig/modules.  I believe using the new configs for the daemon have
> been discussed on this list before.
>
>
> -- Harry O.

Hmm, I have done some searches and not found anything.  I am hesitant
to upgrade if it will break lirc.  Can you point me to the right
resource?


More information about the mythtv-users mailing list