[mythtv-users] Auto detection of media

Peter Lord peter at plord.co.uk
Fri Mar 27 16:09:05 UTC 2009


On Thursday 26 March 2009 18:10:48 Peter Lord wrote:
> Hi All,
>
> I'm currently setting up a combined frontend/backend mythtv box - I'm
> nearly there :-), but I have a few outstanding questions.  I'll post them
> individually.
>
> I'm using .21-fixes from
> http://www.avenard.org/media/Ubuntu_Repository/Ubuntu_Repository.html on a
> M3N78-VM based system.
>
> I would like the frontend to respond when a new media device is plugged in
> (ie SD card, USB, DVD etc).  But I can't get this to work :-(
>
> In the frontend I have enabled "Monitor CD/DVD (and other removable
> devices)" ticked, I don't have "use new media" ticked.  When I insert a USB
> stick/SD card etc, the OS automatically mounts it but mythfrontend does
> nothing.
>
> If I tick "use new media" then without any media plugged in, mythfrontend
> reports "failed to mount device: /dev/sde", and on stdout :-
>
> mount: can't find /dev/sdb in /etc/fstab or /etc/mtab
> 2009-03-26 18:00:52.349 Failed to mount /dev/sdb.
> 2009-03-26 18:00:52.352 Found a handler
> mount: can't find /dev/sdc in /etc/fstab or /etc/mtab
> 2009-03-26 18:00:52.377 Failed to mount /dev/sdc.
> 2009-03-26 18:00:52.380 Found a handler
> mount: can't find /dev/sdd in /etc/fstab or /etc/mtab
> 2009-03-26 18:00:52.402 Failed to mount /dev/sdd.
> 2009-03-26 18:00:52.404 Found a handler
> mount: can't find /dev/sde in /etc/fstab or /etc/mtab
> 2009-03-26 18:00:52.445 Failed to mount /dev/sde.
> 2009-03-26 18:00:52.448 Found a handler
> 2009-03-26 18:00:56.243 XMLParse::LoadTheme using
> /usr/share/mythtv/themes/blootube-wide/gallery-ui.xml
> mount: can't find /dev/sde in /etc/fstab or /etc/mtab
> 2009-03-26 18:00:56.294 Failed to mount /dev/sde.
>
> I think these relate to my SD reader.
>
> Why is myth trying to mount these when there is no media inserted ?
>
> Thanks,
>
> Pete

The devices causing a problem seem to be "removable" - myth is probing 
/sys/block/*/removable and then believes the media is present (which it 
isn't).

So presumably udev magic.

Can I submit a bug report somewhere ?

Thanks.


-- 
Peter Lord (Home)

Electrical Engineers do it with less resistance.



More information about the mythtv-users mailing list