[mythtv-users] Mythfrontend idle cpu consumption help

Daniel Kristjansson danielk at cuymedia.net
Tue Nov 3 15:09:19 UTC 2009


On Mon, 2009-11-02 at 14:07 -0800, Brad Templeton wrote:
> On Fri, Oct 30, 2009 at 12:22:22PM -0400, jansenj wrote:
> I have found much greater use of CPU by the more recent mythfrontends
> over the last year in general.   For example, while my system would
> get decent idle times playing HD content and run quietly, now the
> computer is routinely heating up (and running the fan loud) with
> nothing else on the machine sucking CPU except xorg and mythfrontend.
> (ie. no mythcommflag, which was the only reason the fan would get
> loud before, or perhaps a runaway firefox page.)

I can't speak for your particular machine. However I had
noticed this too on one frontend but after some investigation
found out that the 0.21 MythTV never allowed the CPU to enter
a low power state, so it only appeared to be using less CPU.
When I forced the CPU out of powersaving mode the CPU usage
looked the similar when using the same theme.

Some themes do consume more resources because they use alpha
blends, animations and clocks. This is especially true if you
use the Qt renderer, which does these things using the CPU
instead of the GPU.

During my investigation I also noticed the plasma rendering
engine in KDE 4.x consumes more resources than any other
application on the machine. For a dedicated MythTV machine
it is a good idea to use something lightweight instead.

-- Daniel



More information about the mythtv-users mailing list