[mythtv-users] Problems viewing DVDs with MythBuntu 9.04

Craig Huff huffcslists at gmail.com
Sat Nov 14 17:18:53 UTC 2009


Neither my FE nor my MBE can view a particular commercial DVD.  When I
select "Optical Disks" > "Play DVD", the screen goes blank for a
couple of seconds and comes back.

I can eject the DVD using the menu, but if I hit the eject button on
the drive I get a pop-up window that complains about the device being
invalid -- "Failed to eject
"/org/freedesktop/Hal/devices/storage_model_DVDRW_SHW_1635S.  Given
device ... is not a volume or drive."  This pop-up can only be closed
with a keyboard or mouse attached -- not good for the WAF score.

In checking around, I find that Settings > Removable Drives and Media
> Storage tab has "Mount removable drives when hot-plugged" checked by
default, but unchecking it doesn't help anything, even if I restart
everything.

ls -l /dev/*|grep sr0 shows:
lrwxrwxrwx  1 root   root           3 2009-11-14 07:11 /dev/cdrom -> sr0
lrwxrwxrwx  1 root   root           3 2009-11-14 07:11 /dev/cdrw -> sr0
lrwxrwxrwx  1 root   root           3 2009-11-14 07:11 /dev/dvd -> sr0
lrwxrwxrwx  1 root   root           3 2009-11-14 07:11 /dev/dvdrw -> sr0
lrwxrwxrwx  1 root   root           3 2009-11-14 07:11 /dev/scd0 -> sr0
brw-rw----+ 1 root   cdrom    11,   0 2009-11-14 07:11 /dev/sr0

and with a dvd inserted, df -lh | grep sr0 shows:
/dev/sr0              5.7G  5.7G     0 100% /media/cdrom0

If I go into the Utilities/Setup > Setup > Media Settings > Video
Settings > General Settings (3/7), I see that "Location of DVD
device:" defaults to /dev/dvd, which I should think would be fine, but
I tried /dev/sr0 and /media/cdrom0 just in case -- no improvements.
In fact, with /dev/sr0 I got errors reporting that the device was busy
and already mounted to /media/cdrom0 when a DVD was inserted.

In previous incarnations (FC6/MythTV 0.20?), I think installing a DVD
caused a Myth screen to pop-up and launch the DVD player of choice to
play the DVD, but that isn't happening here.

What change(s) do I need to make to get to where I can play DVDs on my
system, since I doubt I'll have time between now and Thanksgiving to
upgrade/migrate to Mythbuntu 9.10 and MythTV 0.22, and I suspect if
this is fixable in 0.21 it will be less involved ;-)

Any one with words of wisdom to impart?

Craig.


More information about the mythtv-users mailing list