[mythtv-users] mythtv 0.22: danish characters in program guide not displayed correctly

James Warden warjamy at yahoo.com
Fri Nov 20 10:42:03 UTC 2009


Hello,

I am testing a new system, with mythbuntu 9.10 running.
It works very nicely with my DVB-C card (CableStar HD2), nvidia vdpau, lirc, etc. Really impressed.

However, since I live in DK, I need the special danish characters to display correctly.

The system is a brand-new install of 0.22 (mythbuntu ships 0.22.0+fixes22594). The mythconverg status is:

stuetv:~$ mysql -u root -p mythconverg -e 'status;'
Enter password: 
--------------
mysql  Ver 14.14 Distrib 5.1.37, for debian-linux-gnu (i486) using  EditLine wrapper

Connection id:		150
SSL:			Not in use
Current pager:		stdout
Using outfile:		''
Using delimiter:	;
Server version:		5.1.37-1ubuntu5 (Ubuntu)
Protocol version:	10
Connection:		Localhost via UNIX socket
Client characterset:	latin1
Server characterset:	latin1
UNIX socket:		/var/run/mysqld/mysqld.sock
Uptime:			19 min 18 sec

Threads: 7  Questions: 23051  Slow queries: 0  Opens: 922  Flush tables: 1  Open tables: 64  Queries per second avg: 19.905
--------------


And this is where I am a bit puzzled. I read that the defaul characterset was now utf8 (?)

In the TV settings, whether I choose utf-8 or latin1 for OSD playback, I get the danish letters , ,  wrong.

Any hint or tip _?  
The default locale on the system is

stuetv:~$ echo $LANG
en_DK.UTF-8

Thanks,
J.


      


More information about the mythtv-users mailing list